Jump to content
Changes to the Jaspersoft community edition download ×

Does Jaspersoft Studio-6.19.1 (Or Later) Support For Java 17?


shuu

Recommended Posts

Hi.

Our project use Java 17,  But by default the JRE System Library of  Jaspersoft Studio-6.19.1 is java 1.8, 

When I tried to edit or add the JRE System Library it reports an error, then I edited the Jaspersoft Studio.ini and change the -vm value to java 17 and It worked.

The Jasper file has been compiled successfully, But I really wanna make sure that does the Jaspersoft Studio-6.19.1 (Or Later) support for Java 17?

Link to comment
Share on other sites

Thank you for posting to the Jaspersoft Community. Our team of experts has read your question and we are working to get you an answer as quickly as we can. If you have a Jaspersoft Professional Subscription plan, please visit https://support.tibco.com/s/ for direct access to our technical support teams offering guaranteed response times.
 

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Hi all,
I've installed JSS 6.20.6 on a Mac with M1 processor, but in the projects JDK11 is used by default.
There is only a download for  macOS with X86_84. JSS runs, but the log contains several errors.
JasperSoft Studio doesn't seem to run properly on a Mac with Apple Silicon. It's running though. However, errors often occur. Can we predict when a version will be available that also works on macOS with an Arm processor without major errors?
Tanks in advance

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hi, the last version of Jaspersoft Studio 6.20.6 is bundling Temurin JRE 17.0.8.1+1.
The projects use Java 11 as default since we stick to this version as minimum requirement. You can try to modify it, in order to use Java 17 in your project.

Adding/removing new JRE/JDK from the Eclipse preferences requires you to start Jaspersoft Studio application with a JDK instead of a JRE. So you should first download it (i.e. from the Adoptium website) and properly configure the -vm flag in the .ini configuration file.

Regarding the Jaspersoft Studio installation for the M1 (or other Silicon processors) there is already a bug related to it: https://github.com/TIBCOSoftware/jaspersoft-studio-ce/issues/56
Unfortunately I don't have a machine where I can properly work and test a possible dedicated build for such kind of Mac flavor. I'll advise you to follow the GITHUB entry in order to be updated on the topic.
If you are facing any issue please proceed in opening a dedicated bug on the tracker.

Lastly for people using Jaspersoft Studio plugin in different Eclipse flavors it helps give a look at the following article I wrote:

In general for people using the plug-in it is a good idea to give a look at the .ini configuration file of the Jaspersoft Studio stand-alone product. From time to time there could be different flags/properties used in order to properly make the product work.
With the plug-in, there are too many different possible configurations out there and a user might need to proper customize the startup entries in order to fit its needs.

Best regards,
Massimo.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...