Jump to content

Cannot create or update domains

Go to solution Solved by elizam,

Recommended Posts

I just updated today to 5.6 and I cannot modify or create any domains, with a null pointer exception.

I even tried creating a new dataSource to link it to, but to no success. Is 5.6 a beta version? because I am encountering many errors and bugs that were not present before and I'm condering reverting it to 5.5.

Below is the error log from when trying to create a new domain. I just added a couple of tables, joined them and put it all on display. I also tried just adding a new column to display in an existing (and working) domain, with the same error.


Error Message


Error Trace

java.lang.NullPointerException at org.hibernate.criterion.IlikeExpression.getTypedValues(IlikeExpression.java:69) at org.hibernate.loader.criteria.CriteriaQueryTranslator.getQueryParameters(CriteriaQueryTranslator.java:274) at org.hibernate.loader.criteria.CriteriaLoader.list(CriteriaLoader.java:118) at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1597) at org.hibernate.impl.CriteriaImpl.list(CriteriaImpl.java:306) at org.springframework.orm.hibernate3.HibernateTemplate$36.doInHibernate(HibernateTemplate.java:1056) at org.springframework.orm.hibernate3.HibernateTemplate$36.doInHibernate(HibernateTemplate.java:1) at org.springframework.orm.hibernate3.HibernateTemplate.doExecute(HibernateTemplate.java:406) at 


Link to comment
Share on other sites

  • Replies 16
  • Created
  • Last Reply

Top Posters In This Topic

How did you update? I have no problem with systems I've updated from 5.5 to 5.6.

5.6.0 is not a beta.

Check your update log to find if there were any error during the update process.

BYW, if you made any customization to Jaspersoft Server, the update process may have overwritten them.

Link to comment
Share on other sites

The thing is that the update should have been perfect, since I just got a new machine from amazon with 5.6 running and imported my stuff from the old machine. I can't see how that may have caused some issues on the server.


I have tried:

  • Edditing and existing domain
  • Creating and saving a new domain with an existing datasource
  • Creating and saving a new domain with a newly created datasource
  • all of the above with a new superuser account

And all of them have failed with nullPointerException.


Link to comment
Share on other sites

For that I would have to kill my instance and get a new one, and request access to the database, which is a somewhat long process., since there is no restore function (that I am aware of). 

If I am going that route, I might as well stick to 5.5, since it is working fine.

Link to comment
Share on other sites

I have the exact same problem. A couple of days ago we upgraded from 5.5 to 5.6 and now I get a null pointer exception whenever I either edit and save an existing domain or try to create and save a new domain. I'm going to log a ticket with Jaspersoft support because this is a serious issue for us.


Link to comment
Share on other sites

I can confirm this after upgrading from JRS 5.5 to JRS 5.6.

To repro:

  1. From the home screen, select Create Domain.
  2. At the Add New Domain screen, choose a Save Location (e.g., /public/Samples/Domains).
  3. At the Add New Domain screen, select a Data Source (e.g., /public/Samples/Data_Sources/FoodmartDataSource).
  4. Select a schema (e.g., public)
  5. Select a table (e.g., public_account)
  6. Click the Display tab.
  7. From the Resources list, select a table (e.g., public_account), and move it to the Sets and Items list.
  8. At this point the OK button is enabled.
  9. Click the OK button and observe the errror noted by the original poster.

Please let me know how to better debug this issue.


Link to comment
Share on other sites

I have tried using a new instance of 5.6 without importing any of my old data and it worked fine. So I assume there is something (else) wrong with the export/import functions.

I have reverted back to using 5.5 because I cannot afford to put the time to recreate all of my reports and dashboards at this time, but I expect a solution soon. 

Link to comment
Share on other sites

  • Solution

I have not been able to test this, but the bug may have to do with the level at which the admin has been created.  Could someone try this workaround:

You can create an admin at the root level, and give it permission to all the organizations, or you can create an admin at the level of a specific organization. The bug appears to affect admins at the root level.  Therefore, the workaround would be to create an admin at the level of your organization (e.g. organization_1) and create and save domains with that admin. 

In the attached screenshot, you can see the highlighted user does not have an organization, which means it can't create or save Domains with this bug. Lower down you can see two jasperadmins, one for organization_1 and one for Operations - if this workaround is correct, they should be able to create and save Domains. 

If you try this, let me know if it works.

Thank you

Link to comment
Share on other sites

Thank you for the workaround. I have not been able to test it, since I have removed my 5.6 instance to mantain my 5.5 one for the time being. However, I was having this issues when trying to create/update domains using a superuser.
Link to comment
Share on other sites

I had the same reported problem and then used the work around of the admin under an organization rather than the root. It worked and threw no null pointer exceptions when doing it that way. In the error message there was some verbage about multi tenancy, is that part of the bug here where it is only allowing admin under organizations to avoid some sort of security maintenance?

Why prohibit any user who is not under an organization from making a domain? Not sure if this was necessary for something or a bug.

Link to comment
Share on other sites

  • 2 weeks later...

We have multitenancy with SSO enabled to embed into another application. A handful of our staff use direct login to JRS to support clients, but have only ever been able to make it work by making them root level users. Efforts to make org-specific users fail - you can't login to JRS. Have checked the user by using the Login as User button in user area and it works fine. The org is not one of the external clients, it is a special private organization.


Would love to try this workaround, except for this problem with org-users.

Link to comment
Share on other sites

To clarify, only using user created root admin user will expose this defect. If logging into JasperReports Server 5.6 with system generated default "superuser" or any organizational admin users, this error will not occur, based on my testing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...