JasperSoft Studio MacOS "Failed to create the Java Virtual Machine"

-1

Just downloaded version 5.5 of JAsperSoft studio and tried to start it, but got the warning (!) "Failed to create the Java Virtual Machine". And then nothing happens.

I have JDK 1.7.0.25 installed, which works fine on IntelliJ IDEA for instance.

I have MacOS X 10.7.5.

What to do?

regards - Mikael Brodd

mikael.brodd's picture
Joined: Mar 31 2014 - 6:01am
Last seen: 5 years 6 months ago

2 Answers:

0

If you ar ein a Mac you will find this file going to applications and right click on the Jaspersoft Studio.app then select "Show Package Content" the .ini file will be located in Contents/MacOS/JasperSoft Studio.ini 

That file as as @hozawa said all the settings of JSS. In there look at the -vm line it should be pointing to one of your JVM folders, check if that is correct if not point it to your installed JVM it should be something like in my Mac is /Library/Java/JavaVirtualMachines/jdk1.7.0_11.jdk/Contents/Home/ But I'm using MacOSX 10.9 so YMMV

marianol's picture
4708
Joined: Sep 13 2011 - 8:04am
Last seen: 1 year 2 weeks ago

Thanks, now I found the ini-file and edited as you suggested. But still the same behaviour. Here's the contents of the ini-file:

-startup
../../../plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20120913-144807
-data
@noDefault
-clean
-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home
-vmargs
-Xms128m
-Xmx1024m
-XX:PermSize=128M
-XX:MaxPermSize=256M
-XX:+CMSClassUnloadingEnabled
-XX:+UseConcMarkSweepGC
-Dfile.encoding=UTF-8
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts

mikael.brodd - 5 years 6 months ago

Mmmm... Strange and im running out of options:) Looks like something is preventing the JVM to be created. Why don't you open an issue in the JSS bug tracker http://community.jaspersoft.com/bug-tracker?field_bug_project_target_id=496

marianol - 5 years 6 months ago

Just to make this post complete, because I had the same problem.
The full path name should be: /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home/bin
I added the bin folder and it worked for me (in my case I used jdk.1.7.0_55.jdk but that's besides the point)

harry.vanderkolk - 5 years 1 month ago
1

There's a "Jaspersoft Studio.ini" file in the folder where you've installed Studio. Open this file up with a text editor. There should be a following line:

-vm
features/jre.win32.win32.x86_64.feature_1.7.0.u25/jre/bin

Replace the second line with absolute path to your jdk/bin

 

Example:

-vm
C:/Java/jdk1.7.0_25/bin/javaw.exe

 

hozawa's picture
50963
Joined: Apr 24 2010 - 4:31pm
Last seen: 4 months 1 week ago

I'm on a Mac, so sorry, but no, I don't have the ini file there. But I found it through marianol's answer below.

mikael.brodd - 5 years 6 months ago
Feedback