Jump to content
Changes to the Jaspersoft community edition download ×

Reports not refreshing on JasperServer 6.3 (community version)


Recommended Posts


I am running reports with Oracle database, however the data changes frequently. 

When I run a report the first time it takes the data from the database, however if I run it a second time, it produces the previous report rather than re-read data from the database.  How can I make Jasper Server read from the database every time and generate the report.

I read some posts talking about adhoc parameters in Server Settings, but its not show for me, i believe its because de community version.

Is there an way to solve my ploblem?

Thanks in advance.


Link to comment
Share on other sites

  • Replies 7
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

AdHoc reports are only available on Enterprise edition so the information on it doesn't relate to the community edition users.

It seems like your jdbc result is being cached or your page is being cached somewhere. I don't think it's JasperReports Server but more likely the application server you're using or a proxy server. Also check your jdbc string to check if there is any caching argument. Unfortunately, jdbc properties differ depending on the jdbc driver and database you're using so can only give general advice.

Link to comment
Share on other sites

JasperServer: 6.2.0. RedHatx64

Only add last Oracle JDBC lib jar file to JasperServer's Apache Tomcat and configure Data Adapter:

JDBC Driver: oracle.jdbc.driver.OracleDriver

JDBC Url: jdbc:oracle:thin:@//servername:port_number/service_name

Username and password.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...