JasperReports Server 6.1 - UI Disfigured for any Reports.

Jaspersoft Community 'Read-Only' as of July 8, 2022

Transition to New TIBCO Community Just Weeks Away

You can still search, review wiki content, and review discussions in read-only mode. Please email community@tibco.com with questions or issues requiring TIBCO review or response.

The Reports button like Next, Previous, Search buttons are not working in JasperReports. The UI is disconfigured as well. It is attached below for refernce.

Is there a configuration issue that is missing ?

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I downloaded the themes folder from sourceforge website for Jasper Reports.

Zipping it and pushing it uploading it in the Jasper Server UI gets it done and solves the problem.

anurag.anand's picture
Joined: May 31 2015 - 11:12pm
Last seen: 10 months 3 weeks ago

what browser are you using ?

ernst_2 - 6 years 10 months ago

I tried using Firefox and Chrome. Both the places, the same issue exists.

anurag.anand - 6 years 10 months ago

4 Answers:

Check this thread http://community.jaspersoft.com/questions/912636/layout-issue-all-dialog...

I uploaded a Repo Export of the default theme of 6.1 theme there.

marianol's picture
12068
Joined: Sep 13 2011 - 8:04am
Last seen: 3 years 9 months ago

You probably imported the default theme from a different version of JasperReports Server. You'll need to setup another instance of JasperReports Server 6.1 and export Public -Theme - default and import the theme back into the JasperReports Server you're having problem with.

hozawa's picture
131696
Joined: Apr 24 2010 - 4:31pm
Last seen: 3 years 3 weeks ago

Thanks hozawa. Its definitely worth a shot.

Is there any location that you recommend I can get the default theme without installing another version of JasperReports. I am using Jasperreports 6.1

anurag.anand's picture
Joined: May 31 2015 - 11:12pm
Last seen: 10 months 3 weeks ago

There is a Jasperserver 6.1 Pro theme that I added to this thread http://community.jaspersoft.com/questions/912636/layout-issue-all-dialog...

If you need the community one you will need to install it is rather easy and you can install it in your local machine, the only thing you need is the /public/theme

I do not have a clean community installed to export, sorry

marianol's picture
12068
Joined: Sep 13 2011 - 8:04am
Last seen: 3 years 9 months ago
Feedback
randomness