war installation

0

Hello,

I tried to install war package with tomcat 7, mysql and jdk1.8, but during installation the following error appeared:

org.springframework.beans.factory.BeanCreationException:Error creating bean with name actionModelService defined in file ...applicationContext.xml: Invocation of init method failed; nested exception in java.lang.ExceptionInInitializerError.

Could you please help with resolving of this issue.

 

dmitri.trofimenko's picture
Joined: Mar 3 2015 - 2:22pm
Last seen: 1 year 4 months ago

JDK1.8 would be supported in the next version which is expected in July 2015.

chidam.chidam - 4 years 2 months ago

2 Answers:

0

JDK 1.8 is not yet supported in the current release. Use Java 7.

marianol's picture
4575
Joined: Sep 13 2011 - 8:04am
Last seen: 10 months 3 weeks ago
0

I was having some probliems with using OpenJDK7 so I recommend using Oracle JDK 7. I already have several clients using tomcat 7, mysql 5.6, Oracle JDK7 all working without any problems.

 

hozawa's picture
47047
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 months 2 weeks ago
Feedback
randomness