IReport Designer problems running with JDK 8

0
Install the new version of JDK 8 and stopped working iReport Designer. I was running the iReport-5.0.0 version and install the latest version of iReport-5.5.0 but the problem persists. When I try to run from the command window ireport_w.exe tells me the following "The current path is: C: \ Java \ jdk1.8.0The current path is: C: \ Java \ jdk1.8.0Java HotSpot (TM) 64-Bit Server VM warning: ignoring option MaxPermSize = 512m; support was removed in 8.0. "
 
What should I do to run iReport Designer with JDK 8?
ldl720's picture
119
Joined: Mar 8 2010 - 5:25am
Last seen: 4 years 12 months ago

In the previous post I forgot to indicate that eliminates the "-J-XX: MaxPermSize = 512m" File "ireport.conf" to see if this problem was solved, but the problem persists.

ldl720 - 4 years 12 months ago

7 Answers:

5

iReport doesn't support JDK8! Down grade to JDK7.

hozawa's picture
39277
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 hours 11 min ago
1
U! That problem I have already updated my soft JDK 8. I can tell iReport somehow run with JDK 7 version? 
 
Thank you
ldl720's picture
119
Joined: Mar 8 2010 - 5:25am
Last seen: 4 years 12 months ago
-4

This is really a simple question on how to use Java on Windows and doesn't concern JasperReports.

Nevertheless, check the following page on instruction on how to setup Windows to switch between different versions of JDK.

https://blogs.oracle.com/pranav/entry/switch_between_different_jdk_v

hozawa's picture
39277
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 hours 11 min ago
13

Thanks for responding. By way of comment, in case anyone has the same problem, I solve it by modifying the parameter JDKHOME = "C: \ Java \ jdk1.7.0_45" in ireport.conf file. Thus iReport starts with JDK 7 and my software works with JDK 8.

ldl720's picture
119
Joined: Mar 8 2010 - 5:25am
Last seen: 4 years 12 months ago

Thank you for sharing your solution with us.
For all others, ireport.conf file is in iReport\etc folder.

hozawa - 4 years 12 months ago

If you set your JDKHOME on ireport.conf you compile your reports with jdk 1.7 but if you have to load java bean datasource compiled with 1.8 you receive a "major minor version 52.0".
So this solution don't fix problem of jdk 8 and ireport compatibility!

matteo.biviglia - 4 years 4 months ago

persiste el error a pesar que realizo esas modificaciones

alexis5999 - 3 years 5 months ago
0

For those using Jaspersoft Studio, the JDK is specified in "Jaspersoft Studio.ini"

Change the line below to point to your JDK.

-vm
features/jre.win32.win32.x86_64.feature_1.7.0.u25/jre/bin

hozawa's picture
39277
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 hours 11 min ago
11

I found this on Stack Overflow, and it was the solution I was looking for. I hope it helps all of you!

There's another way if you don't want to have older Java versions installed you can do the following:

1) Download the iReport-5.6.0.zip from http://community.jaspersoft.com/project/ireport-designer/releases

2) Download jre-7u67-windows-x64.tar.gz (the one packed in a tar) fromhttp://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

3) Extract the iReport and in the extracted folder that contains the bin and etc folders throw in the jre. For example if you unpack twice the jre-7u67-windows-x64.tar.gz you end up with a folder named jre1.7.0_67. Put that folder in the iReport-5.6.0 directory:

enter image description here

and then go into the etc folder and edit the file ireport.conf and add the following line into it:

jdkhome=".\jre1.7.0_67"

enter image description here

now if you run the ireport_w.exe from the bin folder in the iReport directory it should load just fine.

jeffrey.hegeman's picture
Joined: May 20 2013 - 8:11am
Last seen: 3 years 2 months ago
0

a answer of ldl720 user is great solution.yes

ldl720

chatphol.t's picture
Joined: Oct 18 2016 - 8:04pm
Last seen: 2 years 5 months ago
Feedback
randomness