Jaspersoft Studio 5.5 on Ubuntu 13.10

2

I've install Jaspersoft Studio on Ubuntu and everything seems to be working correctly except for the global menu bar. It's displayed outside of the Jaspersoft Studio on top of the Ubuntu windows, but I can't select it. Has anybody found a way to make it selectable. It seems Eclipse displays the menu bar (file, edit, view, etc) within the Eclipse windows.

I know about the following 2 workarounds but interested in actually solving this problem instead of using the workaround:

workaround 1: Install Eclipse and use the Jaspersoft Studio plugin

workaround 2: Execute the following command to always display menu bar within the application window

sudo apt-get remove indicator-appmenu

Thanks

Hitoshi

hozawa's picture
53210
Joined: Apr 24 2010 - 4:31pm
Last seen: 5 months 1 week ago
There is a much better/simpler solution which is to modify the jasperstudio.desktop file (which you can find in /usr/share/applications) if you used the Debian package file. If you open the file in a text editor (e.g. gedit)

$ sudo gedit /usr/share/applications/jasperstudio.desktop

then you will find something like this:

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Path=/opt/jaspersoft/jaspersoftstudio-5.5.0.final
Icon=/opt/jaspersoft/jaspersoftstudio-5.5.0.final/icon.xpm
Name=Jaspersoft Studio Community
Exec="/opt/jaspersoft/jaspersoftstudio-5.5.0.final/Jaspersoft Studio"
Categories=Office;

Change the Exec line to read
Exec=env UBUNTU_MENUPROXY=0 /opt/jaspersoft/jaspersoftstudio-5.5.0.final/Jaspersoft\ Studio

and the Categories line to be
Categories=GTK;Database;Development;

and it should work fine. Please JasperSoft could these changes be in the standard (Debian) build as they will not affect other Linux users.
john.cockroft.develop - 5 years 9 months ago

1 Answer:

1

Hi,
I recall there was a problem with menu icons in JSS/Eclipse under Ubuntu.
This was the result of the investigation:

============================================================
http://ubuntuforums.org/showthread.php?t=1906823
https://bugs.eclipse.org/bugs/show_bug.cgi?id=293720
http://blogs.operationaldynamics.com/andrew/software/gnome-desktop/where...
Summarizing the solution is to set to true this two settings menus-have-icons and buttons-have-icons. Try to give the following commands from console:

gsettings set org.gnome.desktop.interface menus-have-icons true
gsettings set org.gnome.desktop.interface buttons-have-icons true
============================================================

Please open a bug on the issue tracker. We will have to give a look. Good that you already found some workaround to the problem.
Can you please tell me which Eclipse version + JSS Plugin was working fine? 

Best regards,
Massimo.

mrabbi's picture
8260
Joined: Oct 31 2011 - 9:20am
Last seen: 7 hours 57 min ago
Feedback
randomness