Error when opening the report on Japer Server

0

I build a report in eclipse with jaspersoft plugin. Firstly, when I preview it on eclipse, it shows "java heap space". Then I search this problem on the community, and change the memory of -Xms and -Xmx. It works fine. 

After that, I upload my report to jasper server, and when I run it, the server gives me an error message: “There was an error on the server. Try again or contact site administrators. (Error UID: a0a37c16-5ee7-4c89-915b-791977f09307"

I tried to search this problem on the internet but nothing found. If anyone knows plz let me know, I'm really appreciate it.

victorlizonglin's picture
Joined: May 23 2018 - 12:47pm
Last seen: 1 year 2 months ago

2 Answers:

0

The message simply means there is an error. There may be a a more detailed error and stack trace in the WEB-INF\logs\jasperserver.log file matching the UID of "a0a37c16-5ee7-4c89-915b-791977f09307". This will be more useful for finding the root cause.

vchiem's picture
7020
Joined: May 1 2017 - 5:33pm
Last seen: 3 hours 25 min ago
1

You'll need to check the jaspersserver.log and search for "ERROR" line to find the cause. If it's cause by memory shortage, just increase the memory used by Tomcat. You'll need to restart the server after the change.

https://stackoverflow.com/questions/12688778/increase-tomcat-memory-sett...

hozawa's picture
52592
Joined: Apr 24 2010 - 4:31pm
Last seen: 5 months 1 week ago
Feedback