Jump to content

Grazy Mos

Members
  • Posts

    38
  • Joined

  • Last visited

Grazy Mos's Achievements

Contributor

Contributor (5/14)

  • First Post Rare
  • Collaborator Rare
  • Conversation Starter Rare
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. somehow I got a double post.. Niels, Post edited by: Grazy Mos, at: 2007/02/02 13:33
  2. Installed it and tested it. Shame you didnt fixed the big security bug. You have been aware of this big for over a month now. Yust log in at your jasperintelligence as user and try to acces the admin repositery /flow.html?_flowId=repoAdminFlow I really would appriate some status info about this mayor bug. Is it that hard to solve this? Its cool that you are working on new functionalitíes but I think providing a save product should get a higher priority. Niels,
  3. Sweet another tool, could this be used as a advanced scheduler for jasperintelligence?
  4. I am pretty sure thats the problem Did you found the cause yet? and could we expect its fixed in the new release? Grazy,
  5. I succefully inserted a script into my report and it runs like a charm. The reports uses the script to display some of his fields. I use the script like this: ((HoofdrapportScriptlet)$P{REPORT_SCRIPTLET}).stringToDate(<a string> ) When I tried modifieing the sql statement it gives me the follow error when I read the fields: Sourced file: inline evaluation of: ((HoofdrapportScriplet)Report_SRIPLET).stringToDate(<a string> ) : null Is there a way to fix this error? thanks in advance, Niels v.d Molen Post edited by: Grazy Mos, at: 2007/01/16 10:14
  6. I am writing my own filter that has to catch a custom cookie. After the cookie is succefully catched he needs to try to login that user. In the MetadataAuthenticationProcessingFilter it uses the ExternalUserService class: Code:getExternalUserService().maintainInternalUser(userDetails); getExternalUserService().makeUserLoggedIn(userDetails.getUsername()); The cookie exist of a username and password(USERNAME: PASSWORD). To authenticate(login) this user I believe he has to make a UserDetails object, or add it to the UserDetail object. Or is there a other way to solve this? According to the acigi manual a implementation of the UserDetailService is needed to create a UserDetails object. Does jasperintelligence has a own implementation of the UserDetailService interface? Niels,
  7. Tomcat doesnt gives a error message. The error gets printed on the screen after I select "save as" on the pdf icon, I am using the latest internet explorer. Note that it works if you yust click on it. I am almost sure that function worked a couple of months ago, I doubt its a database issue since I reinstalled the complete database and application, and it didnt worked... It might be a 1.10 issue, I will test it out. edit: I installed the 1.01 version and the "save as" option worked, can some1 confirm that the "save as" function of internet explorer works on 1.10? Thanks in advance, Niels Post edited by: Grazy Mos, at: 2006/12/27 11:50
  8. Hello, For the sake of lazyness, I created a program wich gets a list filled with users from a database. And adds those users to my jasperintellingece mysql database, the program also adds a map for the user and set the rights. These are the jasperintelligence tables where I put data in: for the user: table jiuser(username, fullname, emailAddress, password, externallyDefined, enabled) table jiuserrol(roleId, userId) for the map: table jiresourcefolder(version, uri, hidden, name, label, parent_folder, creation_date) table jiobjectpermission (uri, recipientobjectclass, recipientobjectid, permissionMask) table jiobjectpermission(uri, recipientobjectclass, recipientobjectid, permissionMask) Like 99.5% of the time I add the users it works, but sometimes I get a exception(Cant give you any details on this yet since i didnt save it) After this exception happends it seems that I cant export the reports to any format, my browser tells me this error: Cannot download from exportReport('pdf') no such interface supported I really like to work with this program beceaus it saves me hours of time. Does somebody know if there wich database table could cause this error? Or has any other idea how to solve this? The only thing worked for me so far is reinstalling the database. Thanks in advance, Niels
  9. Sry but I cant help you, still i reply to ask you to keep the question related to eachother in one topic. This will help us get a clean forum There are like 3 jetspeeds/4 LDAP security topics created in the last 2 weeks.. Thanks and good luck with the LDAP issue, Niels
  10. Grazy Mos

    GPL?

    I tried custimizing the layout of jasperIntelligence, i was able to remove the banners, change the titel, and change the colors by editing the .JSP files. Is this viewed as editing the "Source" code? If so.. are you allowed to change it with a commercial license? Thanks in advance, Niels
  11. I discoverd what I did wrong, I added the report and the sub_report with the ireport Plugin. When you add the reports with the normal browser it detects that there is a sub_report and asks you where its located. This wont happen when adding it with the ireport plugin, so he gives a "missing attribute" error when running the report. edit: I believe the sup_report should be located in the resources file at the report unit, But i am not sure if can you get a nested sub report in the resources file, Post edited by: Grazy Mos, at: 2006/12/07 10:36
  12. You're right its not the same problem, its only a report linked to a subreport This was the error: Code:2006-12-06 15:49:32,531 DEBUG [org.springframework.web.servlet.DispatcherServlet] Handler execution resulted in exception - forwarding to resolved error view: ModelAndView: reference to view with name 'JSErrorPage'; model is {exception=org.springframework.webflow.ActionExecutionException: Exception thrown executing [AnnotatedAction@5128b9bc targetAction = com.jaspersoft.jasperserver.war.action.ViewReportAction@7621c3b0, attributes = map[[empty]]] in state 'verifyData' of flow 'viewReportFlow'; nested exception is java.lang.NullPointerException: null} org.springframework.webflow.ActionExecutionException: Exception thrown executing [AnnotatedAction@5128b9bc targetAction = com.jaspersoft.jasperserver.war.action.ViewReportAction@7621c3b0, attributes = map[[empty]]] in state 'verifyData' of flow 'viewReportFlow'; nested exception is java.lang.NullPointerException: null java.lang.NullPointerException at com.jaspersoft.jasperserver.api.engine.jasperreports.util.repo.RepositoryConnection.getInputStream(RepositoryConnection.java:102) at java.net.URL.openStream(URL.java:1007) at net.sf.jasperreports.engine.util.JRLoader.loadObject(JRLoader.java:139) at net.sf.jasperreports.engine.util.JRLoader.loadObjectFromLocation(JRLoader.java:243) at net.sf.jasperreports.engine.fill.JRFillSubreport.evaluate(JRFillSubreport.java:324) at net.sf.jasperreports.engine.fill.JRFillElementContainer.evaluate(JRFillElementContainer.java:277) at net.sf.jasperreports.engine.fill.JRFillBand.evaluate(JRFillBand.java:399) at net.sf.jasperreports.engine.fill.JRVerticalFiller.fillColumnBand(JRVerticalFiller.java:1289) I still cant figure out what i did wrong, note if i run the report without the subreport its works ifne. Thanks in advance, Niels
  13. As far as i know JI makes uses of acegi security, acegi security has the abilities to use different authenticating solutions. If you got the knowlegde how to work with ldap in acegi security you can adjust the apllicationcontext_security.xml and jasperIntelligence will work with it. I guess most peaple on these forums have little/no working experience with setting up customised security systems for jasperintelligence or any other web-application, its more likely to get support from the acegi security community: http://www.acegisecurity.org/ "Official" Forum http://forum.springframework.org/forumdisplay.php?f=33 Did you look in the Reference Guide of acegi security?
  14. I got a similar problem, is the fix already include in the newest version of jasperIntelligence? This is in my master report: Code:<subreportExpression class="java.lang.String"><![CDATA["repo:«»SUP_REPORT"]]></subreportExpression>I loaded a report named SUP_REPORT in jasperIntelligence, When I run the master report in jasperIntelligence it gives the follow error: Code:[code]java.lang.Exception: 1 - null at com.jaspersoft.jasperserver.irplugin.wsclient.WSClient.runReport(WSClient.java:503) at com.jaspersoft.jasperserver.irplugin.wsclient.WSClient.runReport(WSClient.java:409) at com.jaspersoft.jasperserver.irplugin.ReportRunner.run(ReportRunner.java:66) at java.lang.Thread.run(Unknown Source) Any idea what causes this error? And I noticed I needed to put the "url" in a string instead in a java URL, why? Thanks in advance, Niels,
×
×
  • Create New...