Jump to content
Changes to the Jaspersoft community edition download ×

Need help creating a server connection from JasperStudio Professional 6.3.2 to JasperServer


wendy.wells

Recommended Posts

I added a new server connection in JasperStudio to our JasperServer.  We use a CAS SSO which I defined in the connection definition.  When I test the connection it gets an error.  When I right click on it and Open in Browser it opens just fine.  This is the error I am currently getting:

at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:100)
 at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:102)
 at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:97)
 at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:76)
 at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)
 

I have tried several combinations of URL to the server and no matter what I use I get the same results.

Does anyone have any ideas?

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Not sure which steps you've taken.

From Jaspersoft Studio, slect Windows -> Preferences

From the menu on the left hand side, select Jaspersoft Studio -> Single Sign On Servers. Click on "Add" and add your SSO server url.

Then from Repository Explorer, select the JasperReports Server and Edit the configuration.

Expand on "Advanced Settings" and in the Authentication pull-down, select "Single Sign-on"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...