Jump to content
Changes to the Jaspersoft community edition download ×

Unable to get value for Excel field "..." of class.lang.String...!?


dev_34

Recommended Posts

  • Replies 14
  • Created
  • Last Reply

Top Posters In This Topic

In Jaspersoft Studio, all columns are defined as java.lang.String -> that should not matter which values are in excel sheet! Values in excel sheet my be "0" or "my text" - that should not matter.* (But it's NOT a number, it's a string in that problematic row)

* But not vice versa - int datatype in Jaspersoft Studio does not match with string in excel sheet, or genereally, the datasource. (whatever it is..)

Jaspersoft Studio seems to have serious problems with a simple hello world app - that's a lil bit strange in my opinion...

Maybe the problem is that the file was exported from LibreOffice Calc to .xlsx format...?

Link to comment
Share on other sites

  • 2 weeks later...
  • 6 months later...

Now i will test it with the new version 6.9.0, i will not wonder if the problem still persists...;-)

Best regards, Jan



...yes, i was right. Problem still persists.

How to set the data type for a column? Can't see any options related it it. I can only see "Stretch Type" and "Position Type", which are layout things.

Where is the "datatype" setting for a field/column???

Link to comment
Share on other sites

Same Problem here.

I just tried to see if Jasper might be useful to me, but on my first report i got the same error. I tried to change the data type of the field, but it doesnt work. It also seems that this problem exists with every field from the Excel, as it doesnt work if i just remove the field that had the error.

However, i just tried to build a report that based on a .CSV and it did work. Is it possible that Jasper has a Problem with Excel?

Link to comment
Share on other sites

  • 1 year later...

I'm getting the same error when attempting use a .csv file as a data source - "net.sf.jasperreports.engine.JRException: Unable to get value for CSV "weight" of class java.lang.Integer".  The weight column contains nothing more than integers. The .csv file was exported from DBeaver. Does anyone have ideas on what causes the error?

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...