Jump to content
Changes to the Jaspersoft community edition download ×

Error at JasperReport Server 6.4.2 Installation


GonzaLinares

Recommended Posts

As title says, i´m having this issue when trying to install JasperReport Server v6.4.2

Followed standard installation guide  using bundled Tomcat and postgresql database. Did not configure anything manually.

Installation goes well till 6%, while it says:  "copying postgresql database". Then it close without giving any error.

Looking up at log files generated, i got this:

class com.ca.bicoe.cajasperserver.install.guiinstaller.customcode.ShowInstallProgress.install() Unexpected Fatal Error:
java.lang.OutOfMemoryError: Java heap space

Done this installation succesfully 4 times on different servers before, but never got this problem. Any idea what could be wrong?

Link to comment
Share on other sites

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Java heap space
So memory issues. 
How much memory available on the server you are installing ? 
Ussually memory is allocated to JVM as required, most of this time the memory max is set in configuration files. 
Here is some read about that http://blog.sokolenko.me/2014/11/javavm-options-production.html

If you have enought memory, then something else is wrong either the installer is looping and creating threads and not closing any, could be permission level issues.  
Tough to say without further detailed investigation. 

If you have used same installer on same type of os against same java sdk version with same amount of memory. Then maybe your installer got corrupted or there is some difference on the given box you are installing, maybe java classpath is to an older java version or file/program permissions level, something like that. 

Link to comment
Share on other sites

I've often found the default installer getting error during postgresql installation. I wasted time trying to find the cause but finally came to the conclusion that it's faster and more reliable to just pre-install postresql manually and then select it doing the jasperreports server installation.  I found that this almost always works.

Link to comment
Share on other sites

To @joseng62:
Prerequisite for installation is 8Gb. Have 16Gb, so i don´t think it´s a memory problem. About permission level issue, i´m doing the installation logged as an administrator. Last option you mentioned about installer being corrupted i didn´t get it into consideration before, gonna download the installer again and try my luck. 

 

Edit:

Made it work!. Downloaded installer again and turned off anti-virus.
Not sure if it was having trouble with anti-virus or if it worked because old installer was corrupted, but made those 2 changes and it worked.

Thanks for the answers!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...