Jump to content

Redeploy jasperserver-pro for aws


Recommended Posts

Hi we're using jasperserver-pro for aws and I wanted to use the externalAuth application context I configured but whenever I run either the js-install or js-ant deploy-webapp-pro, it gets to the stage where it copies over the files to tomcat and hangs. At first I thought maybe it was taking a while but after 15-20 minutes I figured something must have gone wrong. I checked in the directory and it looks like all the files got copied over properly (I compared to a local jasperserver pro trial) but when I go to the login page I get an apache 404. One thing I noticed at the beginning of the install logs was this:

WARNING: JAVA_HOME environment variable not found[default]Running install-normal-pro Ant task.----------------------------------------------------------------------Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-1.7.0-openjdk-

However when I ran echo $JAVA_HOME it was defined properly. I'm not really sure what to make of this though. Any help would be great.

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Just posting your own comment as an answer so others can benefit :)

Note: When JRS is deploying the Web App to tomcat it does copy a TON of files so it takes some time, also in AWS depending on the instance type you use you may have some IO throttling on your EBS drives, and also is a shared environment so YMMV 

From @srang:

"So..... 20 minutes 53 seconds later: BUILD SUCCESSFUL.

So if anyone else has this problem click deploy, and grab lunch

srang - 4 days 1 hour ago
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...