Jump to content

(Solved) Published report is blank on jasper server


Recommended Posts

Hi All

I have report I designed in Jaspersoft studio. When I run the report in the Jaspersoft studio it works (as in it shows something).

I then publish it to my local jasperserver via the Studio. Go to the jasper server, login and run the report it is blank or rather I get the message "The report is empty".

If I run the published report on the jasper server using the Jaspersoft studio it works. I have cut down every thing from my report so it is not using any database or data connector. 

The report takes 3 parameters and puts them on the report and displays a logo. Any ideas on what to check?



Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Yes it is the datasource. In Jaspersoft studio you have the option for "One empty record" as your data adapter. This allows you to "Test" your report with out a database that provides a record, but you cannot "test" this on the server

I am assuming you have to have a data source for with one record.   Is this correct? 

So I cannot just test a report on the jasperserver without having a valid and active datasource. Is this correct?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...