Jump to content
Changes to the Jaspersoft community edition download ×

iReport should be beta


futile

Recommended Posts

Sorry, but I must vent: iReport is at best a beta-level program. After installing 1.3.1 I press what must be the most basic, essential command 'Report Wizard' and nothing happens! No error, no message, no crash, absolutely nothing happens. My previous installation 1.2.6 required a restart for every configuration change. Furthermore, yes, I bought the manual and it's severely lacking. iReport in no way should be available for general release; it's a joke.
Link to comment
Share on other sites

  • Replies 10
  • Created
  • Last Reply

Top Posters In This Topic

So the fact that you don't charge for the software (lets just forget about the $50 fee for the only half-way decent documentation) means that you can pretend it's production-caliber even when there are huge flaws?
Link to comment
Share on other sites

If you dont like it, then dont use it !!!!

 

I have installed iReport 1.3.1 and everything works perfectly so its a problem on YOUR pc. Dont complain about free software not working as well as you would like it. Be thankfull that the programmers invest so much time in the project.

Link to comment
Share on other sites

Hi Futile,

 

I'm a bit worried about your post. What kind of problems are you experiencing?

 

There are over 1k downloads per day of this application and I don't see posts of people not able to start the wizard or that requires to restart of iReport to apply a changed configuration, so what's wrong with you?

 

Let me know if I can help you in some way, I don't want someone want really believe you... and I happy to have some clear feedback to improve the application usability and stability.

Your opinion is a valuable, but must be more detailed.

 

Thanks

 

Giulio

Link to comment
Share on other sites

Hmm... I don't know how much more clear I can be: I've re-installed 1.3.1 about 5 times now (re-downladed the installer 3 times) (OS Win XP Pro) and when I click the 'New Report' button nothing happens. Clear? This is all I do, install it from scratch and hit that button. Furthermore, clicking File->Report Wizard does nothing.

 

Other problems:

When trying to use a 'JavaBeans set data source' it seems if the factory class has a dependency iReport can't locate the message

'General Problem: package.FactoryClass'

'Check your user name and password. Be sure the DBMS is running.'

'General Problem'? user/pass? DBMS?

 

After finally dodging that red herring, I tried creating a new report (in 1.3.0 of course) with that data source and specifying a bean class in the same package as the factory class. It couldn't find it. I had to package up the class, put it in the 'lib' directory, and then restart for it to be found.

 

Why do I need a factory class to begin with if I'll be passing in the datasource programatically? Turns out there's no reference to the datasouce in the generate jrxml file and it's only necessary for iReport but this isn't stated anywhere.

 

Ok, I'm sick of griping.

I will say one good thing: iReport worked very well for reports than only relied on a database connection

 

One last thing for all you idiots that think iReport is free: Ever wonder why the JavaDoc is so rediculously sparse and there's virtually no free documentation downloadable on the site? BECAUSE THEY MAKE ALL THEIR MONEY ON THE MANUAL ($50 a pop). Oh, those wonderful philanthopist developers so kind to contribute to a free product! I should feel blessed and keep my mouth shut.

Link to comment
Share on other sites

Hi futile,

 

I can't reproduce your problems.

 

Can you give me some basic informations like:

 

what JVM are you using?

what OS are you using?

 

Please try to remove the directory <user home>/.ireport and check if you still get a problem with the "new report" button.

 

If you are working on Win32, can you start iReport using iReport.bat to check if there is an exception on your console?

 

This would help a lot.

 

About dependencies, you have to put all the required classes/jars in the classpath. You can put your classes in <ireport home>/classes if you don't want wrap your classes in a jar.

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...