Can't connect with JasperReports Server

0

Hi all

This is my first time using any JasperSoft software so I apologize in advance if I'm asking a stupid question..

So I have been trying to connect JasperSoft studio with our jasperserver and am failing to do so. Whenever I test my connection I get a 401 (Unauthorized) error, I attached a printscreen below with the data used to fill out the fields. I have also tried creating the connection with the credentials jasperadmin - jasperadmin. 

While searching online, I came across some examples that use the localhost port 8080 to connect to the jasperserver but I don't have access to the computer currently running the jasperserver. Is it necessary to be working on that computer if I want to use JasperSoft?

So basically my question is if the problem for me not being able to connect to jasperserver exists because my account doesn't allow me to create the connection and I have the wrong credentials or because i have to be on the server hosting the jasperserver?

If anything is still not clear please don't hesitate to ask me!

Kind regards
Gravinco

 

Printscreen with connection data:

Gravinco's picture
Joined: Oct 29 2015 - 5:11am
Last seen: 4 years 1 week ago

3 Answers:

0

For URL, write the exact URL which you are using to enter jasperserver via web browser.

remove the '/services/repository/' and add the port number if it is needed.

Probably, It will be sth like that:

https://jnj-mdd-...com:8080/jasperserver

 

zh3ntil's picture
541
Joined: Nov 19 2014 - 11:02pm
Last seen: 3 years 4 months ago
0

Jaspersoft Studio is able to connect with remove JasperReports Server. Are you using the same crediantials that you can log in from your web browser to access JasperReports Server?  Are you using the same version of Jaspersoft Studio as the JasperReports Server you are trying to connect?

hozawa's picture
52732
Joined: Apr 24 2010 - 4:31pm
Last seen: 5 months 1 week ago
0

@hozawa I am using the same credentials I use as when I log in. And when I look at the advanced options for connecting to the server I use JasperReports Library Version 5.1.0. When I click 'About JasperReports Server' in my browser I can see that the Product Version is also 5.1.0.

@zh3ntil I have now tried the exact same thing but with this url: https://jnj-mdd-jasper.imedidata.com:8080/jasperserver/

If I now click 'Test Connection' I get a ConnectException.. Would you like me to post the entire stack trace in my question?

 

Gravinco's picture
Joined: Oct 29 2015 - 5:11am
Last seen: 4 years 1 week ago
Feedback
randomness