Connection to JasperServer from Jaspersoft Studio 5.5 using AWS

0

I am new to Jaspersoft Studio and can't figure out what I am doing wrong when trying to set up my JasperReports Server connection.  JasperReports is running on AWS.

I am entering the url that takes me to the login page.  It works fine if I enter it in my browser.  But, when I test the connection in Jaspersoft Studio I get an error 404(Not Found).

I've tried a few different combinations but no luck.  I am hoping this is something simple and that you'll be able to help me!  

 

Thanks,

Jill

 

 

Attachments: 
jillgeo's picture
Joined: Nov 20 2013 - 9:53am
Last seen: 5 years 3 months ago

1 Answer:

0

Try removing login.html from URL, e.g.:

http://localhost:8081/jasperserver-pro-56/

dnaboka's picture
3927
Joined: Jun 8 2012 - 1:18am
Last seen: 13 hours 33 min ago

That worked - as long as I am also logged in on Jaspersoft Server. I found that having it started was not enough. Thank you!

jillgeo - 5 years 4 months ago

Hi,

Trying to create a connection to my AWS Jaspersoft from my local. I'm typing:

http://ec2.....amazonaws.com/jasperserver-pro/

and the same credentials as I'm using when I'm on the site. I get "Unauthorized"

What am I missing. The only field that I'm doubting is "organization" but it seems it's more for my classifications than real authentication purposes.

Do I need to do something on AWS's security to grant me access? If so, can you point me to the right direction?

CarlCouture - 4 years 11 months ago

if everything is fine regarding organization/user/password, check if version of JasperStudio matches version of JasperServer you are running

dnaboka - 4 years 11 months ago
Feedback