Jasper Web Service don't shows mandatory input control

0

Hi, 

I have two input control "Select Single Query" that I have set as "Mandatory". The second parameter depend on the first. When I run the report in Jasper Server the parameters work well, but when I run it in the Jasper Server Web Service the second parameter remains blank!! How is it possible?

Thank you so much!

giuliana.damiani's picture
Joined: Oct 11 2013 - 1:41am
Last seen: 3 years 6 months ago

Giuliana,

Can you add some color on "run it in the Jasper Server Web Service"? Are you using REST? What webservices calls are you executing to run the report? Can you post an example?

Best!!

MarianoL

marianol - 5 years 10 months ago

MarianoL,

thank you for your reply. I'm so sorry, but I'm not a web service expert..I have windows 8 and I try to run this report on Chrome and on nternet Explorer, but the problem is always the same. As you can see in the image below, when I set the second parameter "Department" on "Mandatory", the windows don't shows the different departments!

 

giuliana.damiani - 5 years 10 months ago

In order to see more details, I suggest to enable logging and see the output. You need to go to Manage->Server Settings and enable log "SQL query executer", please copy the output from server console here.

afomin - 5 years 10 months ago

0 Answers:

No answers yet
Feedback