error when "save as" a report ..need help

0

Hello,

Already I published a post wich is in italic..but it is not the real problem. The problem is that

jasper ireport built with an existing input control ( in a  generic folder of input control) and deployed in the server , when I open the report ,

it cannot be saved as  . However when the input control is created locally in the deployed report ..the save as works.

Could you plz help me to understand why or to resolve it?

thanks a lot

Asma

my first question wish is wrong..

In JSR, I have 

*  3 folders : Public Folder + Personal  Folder  A +  Personal  Folder  B

* 2 users : user_A + user_B

* 2 roles : ROLE_PUBLIC and ROLE_USER  affected to the user_A and user_B

user_ A can not see the Personal  Folder  B and user_ B  can not see the Personal  Folder  A.  here is the grid of rights acess :

  ROLE_USER ROLE_PUBLIC
Public Folder READ ONLY READ ONLY
Personal Folder  A NO ACCESS

NO ACCESS (ROLE)

USER : user A : ADMINISTER

 

Personal Folder  B NO ACCESS

NO ACCESS (ROLE)

USER : user B: ADMINISTER

my problem is that, user A can consult the reports in public folder but can not "save as" them in his personal folder. could you please help me to know why it does not work?

I tried to save as a report example from the the Public folder of jasper and IT works...SO I think that the problem comes from the rights given to my  users but I can not afford it.

thanks for help. and plz feel free to ask me quesitons if my message is not clear.

Asma.

ahamdaoui's picture
Joined: Mar 19 2013 - 10:25am
Last seen: 5 years 5 months ago

Can you confirm which ROLES are assiged to user_A and user_B?

marianol - 5 years 11 months ago

Thanks Marianol for your replay

they have both ROLE_PUBLIC and ROLE _USER...

 

ahamdaoui - 5 years 11 months ago

It seems that there is no reply or resolution to this. My company just got 5.5 Enterprise Edition and we run into the same exact problem. What's more I can't even save report copy into ANY folder other than the one it's deployed in. And I can't do it while logged in as Administrator, so it has nothing to do privilege level. And the error in catalina.out says " Error saving the report as a copy in another directory (uri: /jasperserver-pro/flow.html?null)".

I hoped to find solution already logged, but will have to go through the support then.

ybarkalov - 5 years 8 months ago

2 Answers:

0

This defect is resolved in JasperReports server 5.6, and a hotfix also exists for 5.5.

ghudson_1's picture
24765
Joined: Oct 30 2012 - 12:51pm
Last seen: 22 hours 5 min ago

Where can we found the hotfix ?

psarfati - 5 years 6 months ago

The 5.5 hotfix is available for the professional version of the product, if you are using the professional version of the product, you can open a case via your customer support portal and request it.

ghudson_1 - 5 years 6 months ago

ok thanks

psarfati - 5 years 6 months ago
show 1 more...

Getting the same problem when upgraded from 5.6 to 6.2.1
Is it a problem in 6.2.1 version also?

anirudh0993 - 3 years 4 months ago
0

Thanks for your answer ghudson_1

ahamdaoui's picture
Joined: Mar 19 2013 - 10:25am
Last seen: 5 years 5 months ago
Feedback