JasperReports Sever 4 CE repository on Oracle10g

I thought I had this pinned down from doing it with version 3.5 and 3.7 but I've not.

I've used the handily provided DDL files in the buildomatic folder to create the relevent tables in user jasperdb40 on a local server

I've edited META-INF/context.xml to

<Resource name="jdbc/jasperserver" auth="Container" type="javax.sql.DataSource"
        maxActive="100" maxIdle="30" maxWait="10000"
        username="jasperdb40" password="password"
        url="jdbc:oracle:thin:@" />

I'e altered META-INF/jasperserver-DS-jdbc.xml to


I've changed WEBINF/hibernate.properties to


and edited js.jdbc.properties to



and yet in the apache stdout_<date> .log I still get things like

Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure


Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.

when I stat the MySQL database it all sets going like nothing has changed, even though I've deleted work\\Catelina multiple times.


what do you think? What did I miss?

baggypants's picture
Joined: Apr 7 2009 - 12:43am
Last seen: 14 years 5 months ago

11 Answers:

Here are the full log files from an attempted start with the changes made above in case anyone stumbles on this thead and can make sense of them.

baggypants's picture
Joined: Apr 7 2009 - 12:43am
Last seen: 14 years 5 months ago

found the answer over here


stop tomcat and delete <tomcat>/conf/Catalina/localhost/{web-app-name}.xml

restart and it's all good.

Top Drawer.

baggypants's picture
Joined: Apr 7 2009 - 12:43am
Last seen: 14 years 5 months ago

I was interested in your post as I had 3.7 CE working against an Oracle 10g repository but although I believe I have followed the same steps as yourself I cannot get the login screen to appear correctly using 4 CP (it looks like stylesheets not loading - see attached screenshot).

The steps I have followed are:

run js-create.ddl

run quartz.ddl

run upgrade-oracle-3.7.0-4.0.0-pro.sql

edit hibernate.properties as described in your post

Edit jasperserverDS-jdbc.xml as described in your post

Edit js.jdbc.properties as described in your post

Is there anything I am missing here?


cpsheff's picture
Joined: Mar 17 2011 - 1:33am
Last seen: 12 years 6 months ago

The issue is that for 4.0, the style sheets are stored and looked for in the jasperserver repository.

This enables all the functionality of allowing admins to create customized UI themes and have them be viewable immediately.

But all the theme work is the same for all DB platforms - so if the themes are loaded from the js-catalog-minimal file successfully then I would think that everything should work.

tkavanagh's picture
Joined: Jul 7 2006 - 8:54am
Last seen: 9 years 3 weeks ago

Thanks for that, I realised that I would have to use Buildomatic to get this sorted.

I spotted another question you had replied to re. Oracle & switched from the Windows installer to the jasperreports-server-cp-4.0.0-bin.zip to use this instead.

I have extracted this, copied the oracle_master.properties file to the buildomatic folder & renamed to default_master.properties & entered all the relevant details. I have then made several attempts to either upgrade or create a new db without success.

If I try to use js-install-ce.bat I get the error in the attached js-install-ce_2011-03-29_14-13_13826.log file (I get a similar error when I try using js-upgrade-samedb-ce.bat).

If I try to use the js-upgrade-newdb-ce.bat I seem to get further but it still fails - see attached js-upgrade-ce_2011-03-29_14-51_14208.log file.

I have run through the configuration of import & export utilities but keep getting errors related to the summary error:

Caused by: java.lang.ClassNotFoundException: com.jaspersoft.ji.hibernate.dialect.OracleUnicodeDialect

I have tried editing the db.properties in conf_source\\db\\oracle to ensure all settings are correct & re-generating the build_conf but still no joy.

I have been through the whole of the JasperReports-Server-CP-Install-Guide doc & can't see any other things to try - any pointers would be very gratefully received!

cpsheff's picture
Joined: Mar 17 2011 - 1:33am
Last seen: 12 years 6 months ago

1. Since, Oracle 10g is not certified for Community version, You are not able to find right instrcution in Install guide

2. Regd ur issue :- you need to edit hibernate.properties file and change the dialect to oracle. By Default, it is mysql .


Ramnik Kaur

Senior QA Engineer

ramnik's picture
Joined: Mar 16 2007 - 9:10am
Last seen: 16 years 6 months ago

Thanks, I have tried editing the hibernate.properties but keep getting the error:

     [java] Caused by: java.lang.ClassNotFoundException: com.jaspersoft.ji.hibernate.dialect.OracleU

I guess we are missing something for Oracle databases in CP version?


cpsheff's picture
Joined: Mar 17 2011 - 1:33am
Last seen: 12 years 6 months ago

Shoot, the he OracleUnicodeDialect.java is only in the Pro source code base. I would like to get any of the "pro" database building/configuring files into the Community source code. I'm working on that!

Here is the dialect class, let me know if this works... hopefully there are not other dependencies ...


Hopefully, I'll have more to report to you regarding moving all the "pro" platform support to the Community code base.


tkavanagh's picture
Joined: Jul 7 2006 - 8:54am
Last seen: 9 years 3 weeks ago

Thanks - will try this out as soon as I can!

cpsheff's picture
Joined: Mar 17 2011 - 1:33am
Last seen: 12 years 6 months ago

I've been working with cpsheff on this one and we now have jasperserver-cp-4.0.0 working against an oracle repository with jasperserver installed on windows.

I think that this is a full list of what we had to do to get here.

- get the war file distribution and unpack it

- edit buildomatic\\bin\\validation.xml to allow installation against an oracle database (search for <fail>JasperServer CE doesn't support ${dbType} DB type!</fail> and add a line for oracle just above this)

- edit buildomatic\\conf_source\\templates\\js.jdbc.properties to specify oracle jdbc driver, connection url and repository user name and password

- create and edit default_master.properties from oracle_master.properties as described in installation guide

- copy buildomatic\\install_resources\\sql\\oracle\\js-pro-create.xml and rename it as js-create.ddl (or edit buildomatic\\bin\\db_common.xml to run js-pro-create.ddl instead of js-create.ddl)

- drop a suitable ojdbc.jar into buildomatic\\conf_source\\ieCe\\lib

- create a jar from the OracleUnicodeDialect.class file attached above and drop this in buildomatic\\conf_source\\ieCe\\lib

- run js-install-ce.bat

- once installer completes drop the OracleUnicodeDialect jar into webapps\\jasperserver\\WEB-INF\\lib

- make sure there is an ojdbc jar somewhere in your tomcat

- start tomcat



toddbrook's picture
Joined: Oct 1 2010 - 6:16am
Last seen: 6 years 3 months ago
Hi guys,
here are a few annotations to toodbrook's installation step, thanks for that btw.
if you're like me not familiar how to build a jar file on the console cause usually the IDE is doing that job for you, here you go.
At first create the folder structure "./com/jaspersoft/ji/hibernate/dialect" and copy the OracleUnicodeDialect.class into the last one. If your're working on Linux make sure the class's name is written in camel case. 
Now open the console navigate to the parent folder from "com" and execute "jar -cf OracleUnicodeDialect.jar ./com/jaspersoft/ji/hibernate/dialect/*.class
sappo's picture
Joined: Apr 6 2011 - 12:52am
Last seen: 12 years 5 months ago