Rest Api Jasper Soft

0

Hi Please Help me, Am https://community.jaspersoft.com/wiki/getting-started-rest-web-service-api analysis this api to create jasper report , But It's Sample Rest api Code Could not compile.

Give mvn test :

Got Error like ,

 

[INFO] Scanning for projects...
[INFO]
[INFO] -------< com.jaspersoft.jasperserver.rest.sample:RESTCodeSample >-------
[INFO] Building REST Code Sample 1.0-SNAPSHOT
[INFO] --------------------------------[ jar ]---------------------------------
[WARNING] The artifact org.apache.commons:commons-io:jar:1.3.2 has been relocated to commons-io:commons-io:jar:1.3.2
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ RESTCodeSample ---
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] skip non existing resourceDirectory C:\Program Files (x86)\restapicodesample_1\src\main\resources
[INFO]
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ RESTCodeSample ---
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  0.958 s
[INFO] Finished at: 2019-05-22T13:07:42+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project RESTCodeSample: Error while storing the mojo status: C:\Program Files (x86)\restapicodesample_1\target\maven-status\maven-compiler-plugin\compile\default-compile\inputFiles.lst (The system cannot find the path specified) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

Am tried to fix these issue The artifact org.apache.commons:commons-io:jar:1.3.2 has been relocated to commons-io:commons-io:jar:1.3.2 :

Try: Pom.xml file Changed like :

 <dependency>
        <!-- <groupId>org.apache.commons</groupId> -->
      <groupId>commons-io</groupId>
        <artifactId>commons-io</artifactId>
        <version>1.3.2</version>
    </dependency>

Still It showing error.Please help me.Am tried more than one day Still I can't slove this issue. Please help me It's sample code work or not ??

 

 

 

geethasj03's picture
Joined: May 20 2019 - 12:07am
Last seen: 2 weeks 5 days ago

1 Answer:

0

Hello,

That article you are using is very old. Our new REST API guide can be found here:

https://community.jaspersoft.com/documentation/tibco-jasperreports-server-rest-api-reference/v710/rest-api-overview

I would suggest trying with the new REST API as we are using REST V2 now. 

Thanks,

Paul

pjimenez_2's picture
1185
Joined: Oct 26 2016 - 11:39am
Last seen: 11 hours 8 min ago
Feedback