Jump to content
Changes to the Jaspersoft community edition download ×

Rest Api Jasper Soft


Recommended Posts

Hi Please Help me, Am https://community.jaspersoft.com/wiki/getting-started-rest-web-service-api analysis this api to create jasper report , But It's Sample Rest api Code Could not compile.

Give mvn test :

Got Error like ,

 

[iNFO] Scanning for projects...
[iNFO]
[iNFO] -------< com.jaspersoft.jasperserver.rest.sample:RESTCodeSample >-------
[iNFO] Building REST Code Sample 1.0-SNAPSHOT
[iNFO] --------------------------------[ jar ]---------------------------------
[WARNING] The artifact org.apache.commons:commons-io:jar:1.3.2 has been relocated to commons-io:commons-io:jar:1.3.2
[iNFO]
[iNFO] --- maven-resources-plugin:2.6:resources (default-resources) @ RESTCodeSample ---
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
[iNFO] skip non existing resourceDirectory C:Program Files (x86)restapicodesample_1srcmainresources
[iNFO]
[iNFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ RESTCodeSample ---
[iNFO] ------------------------------------------------------------------------
[iNFO] BUILD FAILURE
[iNFO] ------------------------------------------------------------------------
[iNFO] Total time:  0.958 s
[iNFO] Finished at: 2019-05-22T13:07:42+05:30
[iNFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project RESTCodeSample: Error while storing the mojo status: C:Program Files (x86)restapicodesample_1targetmaven-statusmaven-compiler-plugincompiledefault-compileinputFiles.lst (The system cannot find the path specified) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

Am tried to fix these issue The artifact org.apache.commons:commons-io:jar:1.3.2 has been relocated to commons-io:commons-io:jar:1.3.2 :

Try: Pom.xml file Changed like :

 <dependency>
        <!-- <groupId>org.apache.commons</groupId> -->
      <groupId>commons-io</groupId>
        <artifactId>commons-io</artifactId>
        <version>1.3.2</version>
    </dependency>

Still It showing error.Please help me.Am tried more than one day Still I can't slove this issue. Please help me It's sample code work or not ??

 

 

 

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...