Excel export

0

In a report (Excel export)  I'm creating I have some long texts in a particular field. These texts can be so long that when using the stretch with overflow give a 'weird' result (very high columns). Is it possible to use a property for keeping the complete text but that it fallbacks to Excel default behaviour (so the text is in the cell but only partialy visible and you need to stretch the column to see the complete contents of the cell).

Hope this is a bit clear.

Thanks.

mtn's picture
mtn
106
Joined: Aug 22 2017 - 4:41am
Last seen: 6 months 2 weeks ago

3 Answers:

0

Instead of setting Stretch with Overflow, set the following property in the text field to "true"

net.sf.jasperreports.print.keep.full.text 

 

Select the text field. Select "Advanced" tab in the Properties. Expand "Misc" and select "[Properties: 0]" Search for the above property and set it to "true"

hozawa's picture
64770
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 year 3 months ago
0

Setting this property seems to work but also seems to lead to merged cells when the text becomes longer. Is there a way to prevent this merging of cells? 

Thanks!

mtn's picture
mtn
106
Joined: Aug 22 2017 - 4:41am
Last seen: 6 months 2 weeks ago
0

I'm using Jaspersoft Studio 6.6.0 and can't reproduce the issue or merging cells.

Did you uncheck the "Stretch With Overflow" option?

 

hozawa's picture
64770
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 year 3 months ago
Feedback