*.jasper[Compiled file] is corrupted in server?

Hi All,

one of my *.jasper[Compiled file] is corrupted in server. In the server it is Binary File[BIN], don't know the exact reason for corruption of this. when I downloaded the file from the server and tried to run on my jaspersoft studio it is throwing the error as "Failed to Create the part's control".

When I re-compiled the  *.jrxml then *.jasper file is working fine. Can anyone please help me in understanding the reason for that particular file getting corrupted. I have so many *.jasper files in the server only one of them is corrupted.

Note: In my company we are not using Jasper server

Any help on this is greatly appreciated!!



Duggu09's picture
Joined: Feb 24 2016 - 10:59am
Last seen: 4 years 5 months ago

1 Answer:

There are many reasons to why a file may get corrupted. For example, a file may get corrupted if there is a hardware failure on the disk drive.

If this was the first time you've tried using the file, the file may have gotten corrupted while uploading the file.

hozawa's picture
Joined: Apr 24 2010 - 4:31pm
Last seen: 4 years 3 months ago