unicode font, characters are not coming correctly if exporting to PDF

0

Hello Experts,

I am using Aksar unicode to generate PDF in kannada but, whenever I am exporting it, in preview all characters are coming correctly but in PDF same characters and not showing proerly.I have also tried this with Arial Unicode MS, but it is showing nothing in PDF(blank) while in preview it's coming correctly.

I am using iReport 4.5.0 version.

Please help me, it's a business critical for me.

thanks in advance

abhiishek.info's picture
Joined: Feb 25 2018 - 12:09am
Last seen: 1 year 5 months ago

4 Answers:

0

You'll need to setup font extenstions.

https://community.jaspersoft.com/wiki/custom-font-font-extension

Not sure if it was fully supported in iReports 4.5.0. iReports is depreciated and no longer supported. The new report design tool is Jaspersoft Studio. Characters shows up in PDFs using font extensions and Jaspersoft Studio.

hozawa's picture
47007
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 months 1 week ago
0

Thanks for your reply Hozawa, but I have used font extension only. Problem is only that it's orking preprly in Preview but in PDF some characters are not showing at right place.

abhiishek.info's picture
Joined: Feb 25 2018 - 12:09am
Last seen: 1 year 5 months ago
0

It may be a bug with iReports 4.5.0. It's works well with Jaspersoft Studio.

hozawa's picture
47007
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 months 1 week ago
0

Make sure you specify the correct encoding in the font extension when creating in. In the generated PDF you can also check in document properties -> fonts the list of fonts that PDF contains. Does your PDF contain the required fonts with the expected encoding?

Friendly User's picture
Joined: Oct 8 2009 - 5:59am
Last seen: 4 hours 35 min ago
Feedback
randomness