Jump to content
Changes to the Jaspersoft community edition download ×

ckampshoff

Members
  • Posts

    111
  • Joined

  • Last visited

ckampshoff's Achievements

  1. I'm facing the same issue. Upt o version 6.16.0 everything works fine with the Scriptlet things. After updating to 6.17.0 the Scriptlet doesn't work. I did like the KBA said how to add the Scriptlet to the Jaspersoft Studio. That didn't work. So I put the jar file into my plugins folder. Add the jar file in the Java Build Path Section. Restart the Studio an it doesn't work either. Any other hints why it doesnt'work with the new version?
  2. Hi, thanks for your answer. We solved this issue with the using of an own Scriptlet. We're able to give the database name and the scriptlet connect to the correct oracle database the user selected from a drop down list. At the end of the report we close the connection.
  3. Hello again, I have the CE version of the Jasperserver 5.2. and here everything is fine. I have several reports which are scheduled and work very well. No problems. I'm sorry but I really don't know why it won't work for you. Perhaps sone one else has the pro version of the jasperserver and knows why this won't work. Sorry.
  4. Have you typed in the date / time value or have you chosen it by using the calender control?
  5. Have you test it with two times the "00" for the time value? I had a similar problem, by scheduling a report. I forgot the "nulls" for the seconds and after that it worked for me.
  6. Hi, I think you have to type in the date/time like this : 10.10.2014 09:00:00 Don't forget the the two "00" for the seconds. HTH
  7. Hi at all, I'm trying the new Jaspersoft Studio (CE 5.6.1 final) and I was wondering if there's a possibility to use different data source (other than the one for the main report) for every subreport in one main report. In iReport I'm able to do that by using the "com.jaspersoft.ireport.designer.utils.Misc.getConnection("my datasource")" but I didn't find anything simple like that for the Studio. Only a hint for something like this: net.sourceforge.jtds.jdbc.Driver("jdbc:jtds:sqlserver://192.168.0.144","user","password"). I don't want to write my user and password combination in clear text into my report. Has someone a workaround for this and is it possible to get this on the Jasperserver to work? Kind regards Christina
  8. Hi, you are searching for the variable $V{PAGE_NUMBER}. PAGE_COUNT gives you the number of records on the actual page, as far as I know. Hope this helps Christina
  9. Hi, did you some setting to your table. e.g. Edit the "connection / Datasource Expression"? For that you right click on your table and choose "Edit table datasource". On the first tab choose "Use connection expression". iReport automatically fills the field with $P{REPORT_CONNECTION}. If you have parameters for your datasource you can set them in the same window under "Parameters". Hope this helps. Kind Regards.
  10. Hi, have you tried to fill the "Range Axis Max Value Expression" in the properties of the charts with the same value? Kind regards
  11. Hi, that means that your report can't get any data. Does your Query return some data? Have you created the table with a dataset or as an empty table? If you choose empty table: have you filled it with your fields from your query? Kind regards
  12. Hi, ok let's have another try. Go in the "Report Inspector" to your cross tab. There you have the point "Row Groups" and "Column Groups". Click on the "+" and choose your group so that it is highlighted. On the right side of iReport in the properties window you'll find the point "Bucket Value Class". Please choose your class there. Hope this helps. Kind regards
  13. Hi, I had the same problem. Here's a workaround: switch to the XML-View of your report. There search for "bucket". Then you have to change the lines in the code to something like this: <bucket> <bucketExpression class="java.math.BigDecimal"><![CDATA[$F{MY_FIELD}]]> </bucketExpression> </bucket> For "class" enter the class you need for your field. I hope this helps you. Kind regards
  14. Hi, you can also do this by setting a property expression under the properties of the text field. You should klick "add" and choose net.sf.jasperreports.print.keep.full.text and type in as property value: true. That should work as you expected if you export your report in Excel. Regards Christina
  15. Hi, you should try to do this with the jasperserver. There you can upload your created reports and schedule them. The scheduling is a build-in functionality in jasperserver. Regards Christina
×
×
  • Create New...