Jump to content
Changes to the Jaspersoft community edition download ×

Missing dependencies installing Maven m2e Plugin for Studio 6.20.1


franky4

Recommended Posts

We usually install maven plugin in different versions of Jaspersoft Studio CE including 6.20.0 but in 6.20.1 the plugin cannot be installed with following error:

Cannot complete the install because some dependencies are not satisfiable
  Software being installed: a.jre.javase 14.0.0
  Software being installed: M2E - Maven Integration for Eclipse 2.1.2.20221130-2239 (org.eclipse.m2e.feature.feature.group 2.1.2.20221130-2239)
  Cannot satisfy dependency:
    From: M2E - Maven Integration for Eclipse 2.1.2.20221130-2239 (org.eclipse.m2e.feature.feature.group 2.1.2.20221130-2239)
    To: org.eclipse.equinox.p2.iu; org.eclipse.m2e.launching [2.0.2.20221122-2012,2.0.2.20221122-2012]
  Cannot satisfy dependency:
    From: M2E Launching 2.0.2.20221122-2012 (org.eclipse.m2e.launching 2.0.2.20221122-2012)
    To: osgi.ee; (&(osgi.ee=JavaSE)(version=17))

Has anybody solved that problem yet?

 

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Additional information:

I found that Maven 2.2.1, 2.2.0 and 2.1.2 can be installed, but are not available for use (menu, button in help->about) despite it's show below installation details->installed software. Reports using maven are not running.

Maven 1.17.2 can be installed (same version like Studio 6.20.0) an is show in menu etc. but the reports using maven are not running.

 

 

Link to comment
Share on other sites

Additional information:

I found that Maven 2.2.1, 2.2.0 and 2.1.2 can be installed, but are not available for use (menu, button in help->about) despite it's show below installation details->installed software. Reports using maven are not running.

Maven 1.17.2 can be installed (same version like Studio 6.20.0) an is show in menu etc. but the reports using maven are not running.

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi Franky4, the error appears caused by the plugin requiring a minimum environment involving Java 17, while we are shipping Java 11 JRE.

So:

  • For latest versions there is not much we can do, meaning that we ship a Java 11 JRE. If you want you can try to experiment and play with other versions customizing .ini file pointing to a proper JRE. But indeed this might cause other side-effects.
     
  • For the report not compiling, that could be caused by whatever reasons, please share the logs and the steps you're trying to do so we can see if we can reproduce it locally

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...