Jump to content
Changes to the Jaspersoft community edition download ×

Paragraph Indents in HTML


Go to solution Solved by hozawa,

Recommended Posts

We have a huge problem when our reports are rendering on HTML. This occurs in both  Jasper Studio and Jasper Server . In Jasper Studio when we see reports on Java view are showed correctly, but if we change to HTML not.

We have set Left Indent and Right Indent to 4px and as I say, Jasper respect that on PDF or Java view, but not in HTML views. I've tried setting on the report properties, on the Static Text and Fields properties, using Style Template, almost everything, but nothing change, always we get the same view, NO INDENTS IN HTML. This was tested with Jasper Studio 6.4.2 Pro, Jasper Studio 7.1 Pro, Jasper Server 6.4 Pro and Jasper Server 7.1 Pro; we got always the same result.

I've attach two images with the example. One is the HTML view in Jasper Server and the other one is a PDF export for the same report in Jasper Server.

Exists any solution for this?

Thanks for your help in advance.

html-jasperserver-noindents_1.png.8ddd724d196602d8459ecb7a4b81286a.png

pdf-exported-indentsok_2.png.d09c81e58d13852ac2f3f5b8cfc0711d.png

html-jasperserver-noindents_1.png.36f5d73a31b8482bae0c36f19f13a47f.png

pdf-exported-indentsok_2.png.b04a16c1d97fecfc3e1cac19553f7b6a.png

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...