Jump to content
Changes to the Jaspersoft community edition download ×

Call an URL image with dynamic variable


ajith.devendra

Recommended Posts

Dear ,

I have a Jaspersoft report which need to execute a URL and get the output and using this output need to call an image .. 

let me put it in steps .

1. Call below URL 

http://ImageStore.com:29786/servlet/IRSAccessModule?response=T&doc_id=45997568120&doc_type1=AWB

It will give a output as below with pipe delimiters  

R|4599736190|IR||001|AWB|12794|TIF|image/tiff|2017-11-19 16:35:57|||URL|http://ImageStore.com:29001/servlet/RetrieveImage?image=123232213.awb.001.20171109.173239.tif|

2. read the last field (http://cImageStore.com:29001/servlet/RetrieveImage?image=123232213.awb.001.20171109.173239.tif) in the pipe delimitered file and get the tif image and display .

I would appreciate if anyone can help me on  this .. I'm new to Jasper 

 

Brgds

Aji

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • 1 year later...

hi,

Have you resolved this issue? I meet the same, I use jasper soft 7 final pro, and can't show image by url like this.

example: I want to display "http://www.jasperreports.sourceforge.net/jasperreports.png" to Image Element, but it seem not work with jaspersoft 7.

I see some advice like this:

 

<image onErrorType="Blank" hyperlinkType="None">
<imageExpression class="java.lang.String">

<![CDATA["http://www.translatorscafe.com/cafe/images/flags/"+$F{Country_ISO3166} +".gif"]]>

</imageExpression>

</image>

 

but with the new version of jaspersoft, when I put code: <imageExpression class="java.lang.String">, it's always disapear.

Link to comment
Share on other sites

Hi pro,

Have you resolved this issue? I meet the same, I use jasper soft 7 final pro, and can't show image by url like this.

example: I want to display "http://www.jasperreports.sourceforge.net/jasperreports.png" to Image Element, but it seem not work with jaspersoft 7.

I see some advice like this:

<image onErrorType="Blank" hyperlinkType="None">    <imageExpression class="java.lang.String">        <![CDATA["http://www.translatorscafe.com/cafe/images/flags/"+$F{Country_ISO3166} +".gif"]]>    </imageExpression></image>[/code]

but with the new version of jaspersoft, when I put code: <imageExpression class="java.lang.String">, it's always disapear.

Link to comment
Share on other sites

  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...