Jump to content
Changes to the Jaspersoft community edition download ×

Can not start Jasper Studio


stephane.davy

Recommended Posts

Hello,

I've downloaded Jasper Studio 6.4.3, and alter 6.3.1, but I'm unable to launch it. Each time it fails after a long time and the logs contains the following statement:

!SESSION 2017-10-23 17:27:19.788 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_144
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data @noDefault

!ENTRY org.eclipse.equinox.ds 2 0 2017-10-23 17:29:07.602
!MESSAGE [sCR] Enabling components of bundle org.eclipse.ui.trace did not complete in 30000 ms

!ENTRY org.eclipse.equinox.ds 2 0 2017-10-23 17:29:07.804
!MESSAGE [sCR - WorkThread] Timeout occurred! Thread was blocked on processing [QueuedJob] WorkPerformer: org.eclipse.equinox.internal.ds.SCRManager@3c1d060f; actionType 1

!ENTRY org.eclipse.core.runtime 4 0 2017-10-23 17:29:12.887
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Unable to acquire the state change lock for the module: osgi.identity; osgi.identity="org.eclipse.core.runtime"; type="osgi.bundle"; version:Version="3.12.0.v20160606-1342"; singleton:="true" [id=132] STARTED [sTARTED]
    at org.eclipse.osgi.container.Module.lockStateChange(Module.java:337)
    at org.eclipse.osgi.container.Module.start(Module.java:401)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.util.concurrent.TimeoutException: Timeout after waiting 5 seconds to acquire the lock.

and so on...

My OS is Win 7, I have the same issue if Itry to run it normally or "as administrator". I've seen this issue in some other posts on Internet, but with no real solution.

Your help is welcome

Thanks,

Stéphane

Link to comment
Share on other sites

  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Hello Hozawa,

Thanks for your reply. I've tried actually many times to remove all these lock files, but it doesn't solve the issue. I did install 6.4.3 first, uninstall it and tried with 6.3.1.

It looks like a quite common issue around eclipse, but with no real answer to solve the issue.

Link to comment
Share on other sites

  • 2 weeks later...

Hi stephane.davy,

This may be a possible but crude solution, depending on what eclipse instances exist on your computer.

I had this exact issue attempting to run JasperReport Studio 6.4.3, and in my case, I have had (and still have) many eclipse versions on my machine, as well as multiple versions of Jaspersoft Studio (5.5, 6.1, and possibly 6.3). The only thing that worked for me was going to C:Users<your username and checking for the existence of .eclipse folder.

I tried removing various lock files in the subfolders, but ultimately what worked was taking the entire C:Users<your username.eclipse folder and moving it somewhere else (or deleting it, but I renamed/moved it in order to keep it handy just in case). Please note that this may be breaking or tampering with configurations of other eclipse instances that exist on your computer, so I do encourage backing up that .eclipse folder rather than deleting. 

Interestingly, Jaspersoft Studio 6.4.3 worked after this operation, but didn't need to re-create .eclipse at all.. it just launched without complaining.

If this worked for you as well, I suppose it confirms that Jaspersoft Studio confusingly, and erroneously looks for configuration information outside of it's own configuration folder. I'll try submitting a bug report for this and see if it's acknowledged.

Link to comment
Share on other sites

This re-occurred for me. The follow-up solution was to, since the above solution is no longer valid (namely because that folder was already moved/removed/renamed), Jaspersoft Studio 6.4.3 found issue with some of the .fileTableLock and .tmp*.instance files in the folders and subfolders of ./configuration of the Jaspersoft Studio program folder. I simply deleted those and it started up again. 

Perhaps starting -clean as a command line argument or alternatively as a .ini parameter does this quicker, but I'm not sure.

Link to comment
Share on other sites

Hello jswizardry,

Thanks for your answer. Actually, I also tried to remove .eclipse and all the directories you mentionned, but it doesn't really change the behavior. By the way, I've been able to start it maybe 3 times over 30 attempts.

I've read some similar thread related to eclipse only, some people said that it can be related to the Antivirus, but unfortunatly I'm on a corporate PC on which it's not possible to modify antivirus policy.

Link to comment
Share on other sites

  • 4 months later...

Hi stephane.davy, 

Not sure if you are still wrestling with this. But what I have learned and concluded are the following:

- .eclipse is not the only folder that will impede Jasper's ability to start. I noticed other folders on other workstations, such as one related to ireport (I think it was .ireport or something similar) that can do the same. There's no easy way to determine which folders Jasper is searching for, scanning, and crashing itself with the existence of. Very frustrating.
- Installation of this version is clearly buggy and needs fixing. Perhaps improved in the later versions that have appeared since then ( I think 6.5.1 is out now).

I hope things worked out on your end. Best,

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...