Jump to content
JasperReports 7.0 is now available ×

JasperReports Server


mfio

Recommended Posts

Hi!

I need to config my jasperReports server with appServer jboss 6.4 that is installed on Linux.

I have changed my default_master.properties  on my jasperreports-server-cp-6.4.0-bin distribution 

# appServerType = tomcat
appServerType = jboss-eap-6
# appServerType = jboss-eap-7

# appServerDir = /home/devuser/wildfly-9.0.2.Final
appServerDir = /appserv/jboss/ajb640
 

I have compiled from 

D:jasperReportjasperreports-server-cp-6.4.0-binbuildomatic> 

and I am getting following error.

D:jasperReportjasperreports-server-cp-6.4.0-binbuildomatic>js-ant deploy-webapp-ce

D:jasperReportjasperreports-server-cp-6.4.0-binbuildomatic>echo off
Buildfile: D:jasperReportjasperreports-server-cp-6.4.0-binbuildomaticbuild.xml
     [echo] Filtering properties (cleaning out blank spaces)
     [echo] chkAndSetLocaleDbSettings: dbType is postgresql
     [echo] chkAndSetLocaleDbSettings: db.set.lc_collate and db.set.lc_ctype are NOT both set
     [echo] chkAndSetLocaleDbSettings: parse: scripts.properties for db commands
     [echo]
     [echo] Error: The appServerDir does not seem to be a valid directory:
     [echo] Error: appServerDir=/appserv/jboss/ajb640, fixedAppServerDir=D:/appserv/jboss/ajb640
     [echo] Error: Check that appServerDir is properly set in your default_master.properties file

BUILD FAILED
D:jasperReportjasperreports-server-cp-6.4.0-binbuildomaticbuild.xml:61: The following error occurred while executing this line:
D:jasperReportjasperreports-server-cp-6.4.0-binbuildomaticbinsetup.xml:966: Error: Check that appServerDir is properly set in your default_master.propertie
s file

Why it substitute my path   /appserv/jboss/ajb640,

with              D:/appserv/jboss/ajb640 ?

Could you help me, please?

Where I failed?

Many thanks,

M.

 

 

 

 

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi! 

Thank's for you answer! 

I try with "js-install-ce.bat  test" and  "js-install-ce.bat regen-config"

But the problem is the same.

Error: appServerDir=/appserv/jboss/ajb640, fixedAppServerDir=D:/appserv/jboss/ajb640

My task is to compile jasperserver on my computer (window) and then to deploy jasperserver.war on jboss 6.4 installed on remote computer (linux).

Perhaps I must to compile the package where I have my jboss too? 

Thank's,

M.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...