Jump to content
Changes to the Jaspersoft community edition download ×

Jasper Scheduled Report


Recommended Posts


Currenlty I am using Jasper 5.2 version. We have almost 30-40 reports which are scheduled and i got all of them as per scheduled time.

Sometimes I got blank report as well because it returns no data. Now i want to skip those reports to be email which are blank.

I have checked WhenNoData > No Pages in iReport but it didn't work.


Any suggestion plz ??

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Hi Himanshu,
The issue is you are looking in the wrong direction. No change is required in the report. The change has to be made on Jasperserver.
1) Go to the scheduler properties of that report, Go to the notification tab (Right corner).
2) On the left side, click the very last checkbox that says "Do not send emails for empty reports".
That should help.

P.S. Select this answer as relevant and upvote it if the answer solves your issue, as it may help others with the same issue.


Link to comment
Share on other sites

Hi Kriplani 

I don't see this option (notification tab) in JS 5.2 version. there is only one checkbox saying skip empty report, i have already checked that one but it is also not working. I am still getting blank reports.

Is it possible to do something after the email has been sent…like flag the email red if there’s data in the attached report??  Is there anything that can be done to give us notice that there is data on the report that is sent?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...