Jump to content

Jasper Studio upgrade causing issues


Recommended Posts

I have recently updated to Jasper Studio 6.4 from 6.1 and I'm having a couple of issues.

  1. When I edit a file, and I go to publish it to the server, Jasper Studio is no longer automatically selecting the file location on the server.  I now have to select the correct server, and drill down until I find where the file goes, then select it.  Not only is this a pain, but it is also prone to many more mistakes.  Is this a new "feature", a bug, or is there a setting I can change to fix this?
  2. When I double click (or select "open in editor") on the Main_jrxml from a report unit, I can NOT save changes to this file.  In addition, the temporary file is not saved as a .jrxml, and only the source is available for edit.  There is no design or preview tab available when I open this file again from my local machine.  This appears to be a bug to me.  The only work around is that I download the file to a local directory.  This solution is not ideal since I would either have to create a lot of clutter outside the temp folders, or overwrite my original report.  Neither of these are ideal.

Thank you!


Link to comment
Share on other sites

  • Replies 9
  • Created
  • Last Reply

Top Posters In This Topic

For the location of the file the JasperServer plugin is looking at the following properties:

    <property name="ireport.jasperserver.url" value="http://somewhere:8080/jasperserver-pro/"/>
    <property name="ireport.jasperserver.user" value="superuser"/>
    <property name="ireport.jasperserver.report.resource" value="/public/report1_files/main_jrxml"/>
    <property name="ireport.jasperserver.reportUnit" value="/public/report1"/>

Do you have them set in your JRXML? If not, you may want to specify them manually. If yes, are they set correctly?

As for problem #2 try to either re-create the connection to the JasperServer or take a look at existing connection -> advanced settings. There is a property named "workspace folder". It may point to a folder that doesn't exist in your current workspace. Might be worth specifying a concrete folder if none is specified.

Another thing is to try to run JasperSoft Studio with -clean flag to clear your workspace (add the -clean to the .ini file or shortcut target)



Link to comment
Share on other sites

So, I'm noticing that my main reports (When I download them to file, and can actually save them), seem to be pointing to the correct place.  The subreports are NOT pointing anywhere.  They do not have a value for ireport.jasperserver.reportUnit, but they also are not specific to a single report unit in many cases.  They are being stored in a shared folder, and ireport.jasperserver.report.resource contains the correct file name and location.

I can add a value to ireport.jasperserver.reportUnit containing the same value as ireport.jasperserver.report.resource and it will direct me to the correct path on the server.  But that leads me to wonder if the only way for this to work is to manually add this for each file I work on?

As far for the second problem, the workspace folder is correctly set.  Again, this issue is only occurring for my main reports.  My subreports are working as expected, which leads me to beleive it's not an issue with the workspace for the connection.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 months later...
  • 1 month later...

Nothing about a fix, though I can say that this broken functionality has cost me a lot of time.  Anybody have any posisble solutions?  Anybody at TIBCO want to confirm that this is a known issue that is being worked to be resolved?

Link to comment
Share on other sites

The fastest workaround for your point #2 I have found so far is to download the report from the server like I normally would, Select All and Copy my report's Source XML, and paste it into the Source tab of a New Report that actually has extension .jrxml instead of _jrxml. This then allows me to save and deploy the report as I normally would.

Link to comment
Share on other sites

  • 4 weeks later...
  • 5 months later...

I have the same issue- it's cost me a ton of time as well.  I've tried rolling back to ireport 5.1 but Windows 10 doesn't seem to want to launch it.  Anyone else have this issue?  I prefer to use the ireport 5.1 version because while it isn't technically supported anymore, it's reliable and doesn't seem to need it.  Since I've begun using the Jasper Studio 6.2 version, I've encountered nothing but problems doing what should be simple tasks (such as saving reports with sub reports in them).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...