Jump to content
Changes to the Jaspersoft community edition download ×

Jasper report connection problem - ran from cmd line


zzn

Recommended Posts

Hi,

I have created Jaspert report which uses an xls file as  the data input. It works fine  in the iReport Designer in Preview. I tried to run the report in command line with JasperStarter and I got error:

jasperstarter --locale en pr c:usersxxxMR.jrxml -f view -a -r -t generic -u xxx -p ?????? --db-driver sun.jdbc.odbc.JdbcOdbcDriver --db-url jdbc:odbc:jasperTest; --jdbc-dir "C:Program Files (x86)Javajdk1.7.0_80jrelib" --data-file C:tmpMR.xlsm

Exception in thread "main" java.lang.NullPointerException

at sun.jdbc.odbc.JdbcOdbcDriver.initialize(JdbcOdbcDriver.java:453)

at sun.jdbc.odbc.JdbcOdbcDriver.connect(JdbcOdbcDriver.java:153)

at java.sql.DriverManager.getConnection(Unknown Source)

at java.sql.DriverManager.getConnection(Unknown Source)

at de.cenote.jasperstarter.Db.getConnection(Db.java:140)

at de.cenote.jasperstarter.Report.fill(Report.java:252)

at de.cenote.jasperstarter.App.processReport(App.java:217)

at de.cenote.jasperstarter.App.main(App.java:102)

Can anybody help with this problem? Or is there any other way how to run the report from command line? (I am working with Windows 7, iReport studio 5.6.0, already tried javas 1.7..., 1.8...)

Thanks,

ZZN

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Thanks for hint, I did it.

May be additional question - is there any other possibility how to run the jasper report with xls source from the  command line? It would be great help when starting the development.

Thank you very much

ZZN

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...