Jump to content
We've recently updated our Privacy Statement, available here ×

Changed db password for user "postgres" - What configs need to be updated to get JasperReports to work again?


itgroup
Go to solution Solved by marianol,

Recommended Posts

I changed the password for db username = postgres

It appears that JasperReports had the old password in some config(s) file and now it doesn't work.

What do I need to do here? I'm guessing I need to find the relevant config files and update them? If so, which ones? If not, what do I do?

Link to comment
Share on other sites

  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

We had the same problem with the WAR installation.

The WAR installation explodes with multiple config files and its not an easy thing to find the relevant files which needs to be modified. 

We had to start from scratch and explode the WAR with the required password and then it worked.

 

Link to comment
Share on other sites

  • Solution

You need to change the JNDI connection to the repo, that is defined in <TOMCAT>/webapps/jasperserver-pro/META-INF/context.xml

There look for the JNDI connection called jdbc/jasperserver and change the password to the new one

    <Resource name="jdbc/jasperserver" auth="Container" type="javax.sql.DataSource"
        maxActive="100" maxIdle="30" maxWait="10000"
        username="postgres" password="postgres"
        driverClassName="org.postgresql.Driver"
        accessToUnderlyingConnectionAllowed = "true"
        validationQuery="SELECT 1"
        testOnBorrow="true"
        url="jdbc:postgresql://localhost:5432/jasperserver"
        factory="com.jaspersoft.jasperserver.tomcat.jndi.JSBasicDataSourceFactory"
         />
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...