Jump to content

Recommended Posts


I'm migrating all of my report (more or less 40 reports) designed with iReport 5 to Jaspersoft Studio v.6.0.3

Compiling the report gives me always the same error:

net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
calculator_rpt46visit_1426694094846_413337: 18: unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator 
 @ line 18, column 1.
calculator_rpt46visit_1426694094846_413337: 28: unable to resolve class JRFillParameter 
 @ line 28, column 5.
.....more stuff...
I already checked that groovy.all.2.0.1 jar is in the plugins folder.
Changing language from groovy to java is not a solution for me as almost all the reports are using groovy expressions.
I cannot understand what I'm doing wrong.
Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

could you please open a bug related to this.
Also list the steps you performed when importing the reports inside Jaspersoft Studio (i.e. project creation with jars, etc.). Attach error log(s) and system details too.

If possible also attach a report with groovy that is giving you the issue.
I just tried to create a simple report with SampleDB and language Groovy. It compiled fine.


Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...