Jump to content
We've recently updated our Privacy Statement, available here ×

To generate excel report without page break with virtualizer enabled

Go to solution Solved by Thomas Zimmer,

Recommended Posts


I want to generate excel report without page break and only showing column header in the first page.
As my report size is big one, I am using virtualizer (JRSwapFileVirtualizer). In order to make the virtualizer work I need to set the JRParameter.IS_IGNORE_PAGINATION to false.
But if I set JRParameter.IS_IGNORE_PAGINATION to false then report is getting generated with page break and column header in each page.
So how to generate report without page break and without repeating column header in  each page (one long report) with virtualizer enabled?
I have attached the report which I am getting.
Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

  • Solution

This issue was addressed several times: http://community.jaspersoft.com/jasperreports-library/issues/4594 , http://community.jaspersoft.com/questions/530836/ignore-pagination-and-virtualizers

However, I can not see a solution in the discussions.

Did you try to use band filters? With them, you could achive the same xls-view without pagination:




But I do not know how it works in conjunction with file virtualizer (but i don't think that should make problems)

Cheers, Thomas


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...