Jump to content
Changes to the Jaspersoft community edition download ×

Problems deploying 2.0.1 from .WAR


hazamonzo

Recommended Posts

Hello folks.

 

I have been trying to deploy JI from the .WAR file for a couple of days now with no luck so far.

 

Here is some information:

 

JI 2.0.1.WAR

Tomcat 5.5.23 - Fresh install

MySQL 5.0.27

JI 2.0.1 jasper-server-install-guide.pdf

 

I have followed the steps for deploying JI with tomcat:

 

Created the jasperserver database and populated it with the basic records (16 records for basic population)

 

Created the jasperadmin user for the database and assigned privileges

 

extracted the .WAR file into the webapps folder under jaspersever

 

Edited the webapps/METE-INF/context.xml file with the correct settings for database connection

 

Checked that the settings where right in the webapps/WEB-INF/hibernate.properties

 

Started up tomcat (list of errors)

http://localhost:8080 works

http://localhost:8080/jasperserver returns a 404 error.

 

I am happy to post log files and config files on request. Maybe someone out ther could help me?

 

Best regards,

 

Harris

Link to comment
Share on other sites

  • Replies 15
  • Created
  • Last Reply

Top Posters In This Topic

Hello again folks.

 

After playing around a little more i can provide more information.

 

I decided to also use the JI 2.0.1 installer. So now i have 2 copies of JI. one using the installer and one build from the .WAR file. Here is what i have found out.

 

As a quick test i decided to copy the jasperserver folder in the webapps from the INSTALLED verion and overwrite the jasperserver folder in my other copy of JI (the one built from the .war file). I then loaded my version of tomcat with the INSTALLED versions jasperserver folder (making sense so far?)

 

It looks like this did not work which leads me to think sometjing might be wrong with my version of tomcat. I then decided to try it the other way round and copied my version of the WAR file from my tomcat and overwrite the INSTALLED verion. I loaded the INSTALLED version of tomcat and it did work!

 

This means that the build on my server of the >WAR file is configured correctly. It just doesnt work on my version of tomcat(fresh install by the way)

 

I also noticed that the INSTALLED version runs on tomcat 5.5.20 and my version is 5.5.23

 

Is it a version problem or maybe there is somethig i need to configure on my tocat to get my .WAR file working?

 

Hope that helps. Any pointers?

 

Best regards, Harris

Link to comment
Share on other sites

This may also be of use to a Java developer.

 

I have attached the logfile from ROOT/webapps/jasperserver/WEB-INF/logs

 

Theres i lovely big error message in there. If someone could have a look at it i appreciate it! :)

 

Best regards, Harris

 

[file name=jasperserver-5089c3f03a7af44c2e8e779fb246cd95.txt size=66985]http://www.jasperforge.org/components/com_joomlaboard/uploaded/files/jasperserver-5089c3f03a7af44c2e8e779fb246cd95.txt[/file]

Post edited by: hazamonzo, at: 2007/08/22 13:59

Link to comment
Share on other sites

Hi Lucian,

 

I have installed another instance of tomcat configured to use jre 1.5.0_10 and then places the jasperservre webapp in the right directory. start up tomcat and i get this error message

 

Best regards, Harris

 

 

[file name=part2.txt size=174455]http://www.jasperforge.org/components/com_joomlaboard/uploaded/files/part2.txt[/file]

 

Post edited by: hazamonzo, at: 2007/08/22 15:36

Post edited by: hazamonzo, at: 2007/08/22 15:37

Link to comment
Share on other sites

Harris,

 

I found this in the log from part1.txt:

 

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)

 

Caused by: java.lang.ClassNotFoundException: com.mysql.jdbc.Driver

at java.net.URLClassLoader$1.run(Unknown Source)

 

So, it looks like jasperserver is not finding the database driver. Check <tomcat>/common/lib and see if the mysql driver has been copied from the <unpacked-war-dir>/scripts/drivers directory

 

Also, see section A.6.6 Copy Database Driver in the jasperserver-install-guide.pdf (page 15).

 

Regards,

 

-Tony

Link to comment
Share on other sites

Hi Tony,

 

Its very odd that you should get that message in the error log as i did copy the mysql driver into the commom/lib dir

 

mysql-connector-java-3.1.12-bin.jar

 

Any other thoughts maybe? Maybe if it isnt too much trouble someone would like to try and deploy the 2.0.1 WAR file on tomcat 5.5.23? See if you get the same problems. At least then i will know im not the only one ;)

 

Best regards,

 

Harris

Link to comment
Share on other sites

Well its not looking good :(

 

This has to be the 10th time ive tried to deploy with the .WAR file and failed. I even looked for an older version of Tomcat (5.5.20, the same one included with JI 2.0.1 installer)

 

It doesn`t matter how many times i follow the "Jasper server install guide" simple steps (and they are very simple) i still get the same error messages. I cant decode these error message as i am pretty new to Java development. Any help is appreciated.

 

Thanks you all in advance! :)

Link to comment
Share on other sites

Indeed, there's a problem in 2.0.1.

 

A (temporary) workaround: edit WEB-INF/applicationContext.xml, find a bean named profileAttributeServiceTarget and remove/comment its repositoryService property. This is a safe workaround for the moment, a proper solution will be provided in the future.

 

Regards,

Lucian

Link to comment
Share on other sites

I just did a test manual install from the war file bin zip and it worked fine for me. I installed the "minimal" JasperServer (ie no sample data).

 

I'm using:

 

Windows XP

Tomcat 5.5.15

MySQL 5.0.18

Java 1.5.0_06

 

I'm thinking we should maybe re-set the table. Perhaps the thing to do is to turn off tomcat and mysql and use the installer instead and let the installer put a bundled tomcat and bundled mysql on your machine. Then maybe we can get you to the login page! Are you running on Windows or Linux?

 

Regards,

 

-Tony

 

PS. I'm checking with Lucian on the problem he found with applicationContext.xml

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...