object not found creating new report

0
My first attempt at JasperSoft Reports, community edition.Installed the necessary plugin to get it to work in Spring Tool Suite. Created a new report project and added the data adapter to connect to a sql database and the connection worked fine. Then tried to create a new report and select a datasource and design a query. This is where the error is produced:
 
 
    user lacks privilege or object not found: 
 
and the object in this case happens to be the DB table. I have been unable to retrieve any solution online and hoping someone can direct me here.
Appreciate your response.
jdeppuser's picture
Joined: Apr 16 2014 - 3:05pm
Last seen: 2 years 8 months ago

Hozawa

Thanks for your response. Yes, within the datasource selection in the report wizard I selected the data adapter but not sure what the dataset you referring to.

As I mentioned above, I tested the data adapter with the test connection and it worked fine so user credentials show privileges.

 

Could you please look at the image:

jdeppuser - 3 years 2 weeks ago

Does anyone have any tutorials or example related jasper projects that are created within spring tool suite?

jdeppuser - 3 years 2 weeks ago

1 Answer:

0

Did you select the data set (second icon from the left) to use in your report? Does the user you've set in the data adapter have privileges to the table you wish to use?

hozawa's picture
42197
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 day 17 hours ago
Feedback