Table example from tutorial ends with NPE in Jaspersoft Studio

0

Hi everybody,

at the moment I'm evaluating Jaspersoft Studio. So i came to the example for tables https://community.jaspersoft.com/wiki/tables-and-crosstabs-jaspersoft-studio

But whenever I want to add a table from the palette and follow the instructions in the section 'The Tables', I get stuck : whenever I try to finish the wizard, I get a NullPointerException. It doesn't matter, if I use a blank report or the cherry table template, if I use a new or existing data source (or even an empty data source) : i always get a NPE and there is no source code produced in the jrxml file.

I tried already to re-install, install on a different computer, install in an existing eclipse 4.4 as plug-in, different JREs (1.7 and 1.8), start with -clean option etc. No difference...

I guess, that I made something wrong in some settings, because i couldn't find anything about this kind of error here and it comes from Jface (see stack trace), but merely I got stuck here.

Btw, when I use the cherry template, the initial table that is already contained in the template is created and runs perfectly. But adding another one leads to the NPE again.

 

I appreciate any help and tips very much, many thanks in advance !!!

 

Full stack trace from log file:

!ENTRY org.eclipse.jface 4 2 2015-04-22 11:38:14.247
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.NullPointerException
    at com.jaspersoft.studio.components.table.model.table.command.CreateTableCommand.createObject(CreateTableCommand.java:106)
    at com.jaspersoft.studio.model.command.CreateElementCommand.execute(CreateElementCommand.java:327)
    at org.eclipse.gef.commands.CommandStack.execute(CommandStack.java:199)
    at com.jaspersoft.studio.editor.dnd.JSSTemplateTransferDropTargetListener.handleDrop(JSSTemplateTransferDropTargetListener.java:340)
    at org.eclipse.gef.dnd.AbstractTransferDropTargetListener.drop(AbstractTransferDropTargetListener.java:183)
    at org.eclipse.jface.util.DelegatingDropAdapter$3.run(DelegatingDropAdapter.java:211)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
    at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
    at org.eclipse.jface.util.DelegatingDropAdapter.drop(DelegatingDropAdapter.java:209)
    at org.eclipse.swt.dnd.DNDListener.handleEvent(DNDListener.java:90)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
    at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:774)
    at org.eclipse.swt.dnd.DropTarget.Drop(DropTarget.java:456)
    at org.eclipse.swt.dnd.DropTarget.Drop_64(DropTarget.java:392)
    at org.eclipse.swt.dnd.DropTarget$3.method6(DropTarget.java:260)
    at org.eclipse.swt.internal.ole.win32.COMObject.callback6(COMObject.java:119)
    at org.eclipse.swt.internal.ole.win32.COM.DoDragDrop(Native Method)
    at org.eclipse.swt.dnd.DragSource.drag(DragSource.java:363)
    at org.eclipse.swt.dnd.DragSource.access$0(DragSource.java:289)
    at org.eclipse.swt.dnd.DragSource$1.handleEvent(DragSource.java:172)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4169)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3758)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:96)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

J.Pook's picture
9
Joined: Apr 16 2015 - 1:38am
Last seen: 5 years 1 month ago

Can you please detail on which version of JSS plugin you installed? Last version 6.0.4?

mrabbi - 5 years 5 months ago

I just tried to run the table samples using both the development environment and the JSS 6.0.4 installed into a Luna 4.4.2.

No exception was raised following the steps proposed in the tutorial.

Regards,
Massimo.

mrabbi - 5 years 5 months ago

1 Answer:

0

Hi,
I will try to verify the steps of the tutorial in order to reproduce your error.
Next time when you face exception or errors please open a bug in the tracker so we can better handle the issue.

Thanks.
Regards,
Massimo.

mrabbi's picture
10400
Joined: Oct 31 2011 - 9:20am
Last seen: 3 weeks 5 days ago
Feedback
randomness