Remote access via REST not working

0

 

Server is community edition, 6.0.1.  Studio is community edition, OSX, 6.0.1-final

When trying to create a new server connection to the Jasper Reports server I have to select "Use SOAP protocol only".  If not I get the following error on "Test Connection":

 

java.lang.UnsupportedClassVersionError: com/jaspersoft/studio/server/protocol/restv2/JSSApacheConnectorFactory

at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:134)
at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:86)
at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:82)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:99)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:95)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:76)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
 
When I test REST using this URL it seems to come back OK:   <hostname>:8080/jasperserver/rest_v2/resources?type=reportUnit
 
mike_41's picture
Joined: Jan 26 2015 - 11:02am
Last seen: 6 years 2 months ago

2 Answers:

0

Hi,
the error you are receiving it is a bug caused by some Jersey libraries compiled only for Java 7.
This has been fixed in the next upcoming 6.0.2 version. You can test it already in the available beta build from here: https://sourceforge.net/projects/jasperstudio/files/beta-release/

Plus unfortunately in Mac OS X, Eclipse/JSS was not receiving correctly the -vm flag that specifies to use the bundled JRE.

You can proceed in one of the following ways:

1) Download and test the beta build, a stable version will be available soon

2) Fix the -vm flag argument in Jaspersoft Studio.ini file to something like this: ../../../features/jre.macosx.cocoa.x86_64.feature_1.7.0.u67/jre/Contents/Home/lib/jli/libjli.dylib 
You need to right click on the Jaspersoft Studio.app, "Show package contents" and navigate to Content/MacOS.
In this way JSS will be forced to use the internal bundled JRE 1.7.0.u67 preventing the error from appearing.

3) I expect that also installing a JDK 1.7 will solve the issue. Not tested yet. I suppose that in your system you are currently relying on the Mac OS X Java (that is a 1.6). You should be able to verify the available Java version giving "java -version" in your terminal.

Regards,
Massimo.

mrabbi's picture
11528
Joined: Oct 31 2011 - 9:20am
Last seen: 2 weeks 9 hours ago

-

amey.jadiye - 6 years 2 months ago
1

Simplest solution i found is try selecting option in "Advanced settings > Use SOAP Protocol only", this solved my problem

amey.jadiye's picture
Joined: Feb 3 2015 - 6:09am
Last seen: 6 years 1 month ago

Indeed using SOAP can help, but unfortunately the SOAP API are no longer maintained in JRS.

mrabbi - 6 years 2 months ago

Can you tell me where to find the Use SOAP Protocol only? I cannot find an "Advanced Settings" option under Preferences. (Using Studio community edition 6.0.1)

lmercier_1 - 5 years 2 months ago
Feedback
randomness