New to admin'ing jasperserver, report not running, getting error

Jaspersoft Community 'Read-Only' as of July 8, 2022

Transition to New TIBCO Community Just Weeks Away

You can still search, review wiki content, and review discussions in read-only mode. Please email community@tibco.com with questions or issues requiring TIBCO review or response.

Error Message:

An error occurred. Please contact your system administrator.

Error Trace:

com.jaspersoft.jasperserver.api.JSException: jsexception.error.creating.connection

com.jaspersoft.jasperserver.api.JSException: jsexception.error.creating.connection
	at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.JdbcDataSourceService.createConnection(JdbcDataSourceService.java:62)
	at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.BaseJdbcDataSource.setReportParameterValues(BaseJdbcDataSource.java:52)
	at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.JdbcDataSourceService.setReportParameterValues(JdbcDataSourceService.java:67)
	at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.executeQuery(EngineServiceImpl.java:1026)
	at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.executeQuery(EngineServiceImpl.java:987)
	at com.jaspersoft.jasperserver.war.action.ReportParametersAction.executeQuery(ReportParametersAction.java:514)
	at com.jaspersoft.jasperserver.war.action.ReportParametersAction.createWrappers(ReportParametersAction.java:477)
	at com.jaspersoft.jasperserver.war.action.ReportParametersAction.createWrappers(ReportParametersAction.java:414)
	at com.jaspersoft.jasperserver.war.action.ReportParametersAction.createWrappers(ReportParametersAction.java:123)
	at com.jaspersoft.jasperserver.war.action.ViewReportAction.checkForParams(ViewReportAction.java:148)
	at sun.reflect.GeneratedMethodAccessor488.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.springframework.webflow.util.DispatchMethodInvoker.invoke(DispatchMethodInvoker.java:103)
	at org.springframework.webflow.action.MultiAction.doExecute(MultiAction.java:136)
	at org.springframework.webflow.action.AbstractAction.execute(AbstractAction.java:203)
	at org.springframework.webflow.engine.AnnotatedAction.execute(AnnotatedAction.java:142)
	at org.springframework.webflow.engine.ActionExecutor.execute(ActionExecutor.java:61)
CTrimble's picture
Joined: Aug 19 2014 - 7:19am
Last seen: 7 years 2 months ago

Not sure how to fix this. Any help is greatly appriciated.

CTrimble - 7 years 10 months ago

2 Answers:

The problem was that the server this was point towards was moved off site to a hosted environment and the firewall had to be configured for an IPSEC tunnel to that server's ip in order for the connection to work. Only then could the datasource connect.

CTrimble's picture
Joined: Aug 19 2014 - 7:19am
Last seen: 7 years 2 months ago

Did you define and test your datasource? You'll need to define your datasource in JasperReports Server. Jaspersoft Studio should have asked you to specify a datasource when you uploaded your report layout.

hozawa's picture
131858
Joined: Apr 24 2010 - 4:31pm
Last seen: 3 years 3 weeks ago

I did not upload the report. This system was in place when I took over. Since the report is already there, how do I define and test my datasource?

CTrimble - 7 years 10 months ago
Feedback
randomness