JTDS issues when setting up Data Source

0

Hello All,

I recently set up a small test machine (XP Pro) and installed Jasperserver Community Edition to test out functionality. I configured my Data Source (SQL 2008) using the JTDS driver (1.3.1) and everything has been working great.

I received approval to purchase some addtional hardware, but due to budget constraints i opted to install on Ubuntu Server instead of purchasing Microsoft Server. I installed Tomcat 7 and PostgreSQL and used the manual WAR installation to set up Jasperserver. Everything seems to be running great as far as the server and the installation of Jasperserver. I am able to log into the JasperServer Web portal without error.

I copied the JTDS driver into my  jasperserver/WEB-INF/lib folder and rebooted, but when i attempt to set up the Data Source I receive an Error Box that is completely blank. I have attempted to turn on logging for the JDBC driver but so far I have been able to generate any log files.

I guess my biggest concern is that maybe the JTDS driver does not work with OpenJDK 6, but i am not 100% if that is the case

Any help or insight is appreciated.

 

Adam

adam_7's picture
39
Joined: Jan 27 2014 - 7:59am
Last seen: 1 year 2 months ago

2 Answers:

0

May be you're right. Should try Oracle JDK 1.7

http://bugs.java.com/bugdatabase/view_bug.do?bug_id=7105007

hozawa's picture
56332
Joined: Apr 24 2010 - 4:31pm
Last seen: 7 months 2 weeks ago
0

Sun Java isnt supported under the Ubuntu Repositories, i tried to install it manually using some instructions online but it would crash Tomcat whenever i attempted to run a report.

I ended up reinstalling Open JDK 6 since it is supported by JasperServer and switched my JDBC driver to the Microsoft Driver instead of the JTDS Driver.

adam_7's picture
39
Joined: Jan 27 2014 - 7:59am
Last seen: 1 year 2 months ago
Feedback