Jaspersoft Studio query editor flags syntax errors on mySQL query that works fine in iReports

0

Odd issue here:

  • Just installed Jaspersoft Studio 5.5 (OS X Mavericks)
  • Connected to external mysql database just fine
  • Entered a query I've been using for months in iReport without issue
  • Studio query editor shows syntax errors in several places (e.g., mismatched input, mismatched character)
  • Can't preview data
  • Can't preview report (java.lang.IllegalArgumentException: Null 'dataset' argument)

Anybody know why this query would suddenly stop working on Studio 5.5? 

schneider.luke's picture
Joined: Jan 30 2013 - 7:27am
Last seen: 2 years 10 months ago

1 Answer:

0

Have you selected a proper data adapter for your report? Remember that studio uses data adapters (instead of datasources) and the report remembers the specific data adapter that you havce chosen. C

reating the data adapter does not means that Studio will use it for all the reports you open (like iReport did). In Studio each report remembers the data adapter you have selected previously for that report when running.

If you imported the report from iReport; Studio will have no data adapter assigend to that report and you have to pick one before you can run your query.

marianol's picture
4575
Joined: Sep 13 2011 - 8:04am
Last seen: 10 months 3 weeks ago

Thanks, Marianol.

I have selected the proper data adapter. It's as if the acceptable mysql syntax has just changed between the two products (iReport and Studio). When I run the identical query in Sequel Pro and iReports I get a normal dataset returned. The error I get when I try to "read fields" in Jaspersoft is a "check your SQL syntax . . ." . The red "X" marks in the query editor indicate mismatched inputs and missing EOF when I mouseover them.

schneider.luke - 5 years 6 months ago

I used a query generated by Toad and tried to add where with a parameter and it gave an EOF error in the query window. I moved it above the group and order clauses and it worked.

jimj - 3 years 3 months ago
Feedback