Jaspersoft Studio: "Failed to create the Java Virtual Machine" at startup

3

Win 7 Professional 32bit, Java -version = 1.7.0.51

Just installed "Jaspersoft Studio-5.5.0.final-windows-installer-x86.exe", everything left at default value.

When I start JS Studio, a window contaning the error message above appears. Software does not start.

Other PC, same Windows, same Java: no problem.

Anyone had this error and found out why this happens?

Thank you.

 

gast951's picture
17
Joined: Jan 21 2014 - 12:24am
Last seen: 5 years 3 months ago

2 Answers:

0

Hi, 
can you please file a bug in the Issue Tracker? It will be much easier to track the problem. 
Please remember to attach any error logs produced.

Best regards,
Massimo.

mrabbi's picture
6230
Joined: Oct 31 2011 - 9:20am
Last seen: 1 week 3 days ago

Thank you, no bug tracking needed, but perhaps interesting for others:

I found out that there is a second JRE (Java 6) on the PC where ist fails. I deinstalled this one. After this JS Studio started.
No other action, not even Windows restart: JS Studio won't start -> deinstall second old JRE -> JS Studio starts.

But when I double clicked a .jrxml file in Eclipse, I still got the error message.
But not, if I right clicked it, chose "open with" and selected JS Studio.
So I associated .jrxml files in Eclipse (Window-Preferences-General-Editors) with JS Studio, and now also double click opens JS Studio.

Regards
Rudi

gast951 - 5 years 3 months ago
11

This worked for me to resolve the above error:

- Go to the Jaspersoft Studio installation folder, open ‘Jaspersoft Studio.ini’ file using Notepad and edit it as below.

- Find the line -Xmx128m (or -Xmx1024m). Now change the default value 128m (or 1024m) to 512m.

- Save and close it.

- Now you should be able to open Jaspersoft Studio without getting the error message.

deepakpatro's picture
Joined: Apr 17 2014 - 5:36am
Last seen: 5 years 12 hours ago

Thank you! This worked

mcampbell_1 - 4 years 11 months ago

Had the same error message and this worked, much appreciated!

david.kanizsai - 3 years 8 months ago
Feedback