Error Closing Context

7

Just installed jasperserver 5.5... manual install... Which installed successfully however, when i go to run the server i get the following error:

 

2013-12-09 15:35:47,869 ERROR JNDIResourceProvider,localhost-startStop-1:75 - error closing context
javax.naming.OperationNotSupportedException: Context is read only
        at org.apache.naming.NamingContext.checkWritable(NamingContext.java:962)
        at org.apache.naming.NamingContext.close(NamingContext.java:762)
        at com.tonbeller.tbutils.res.JNDIResourceProvider.close(JNDIResourceProvider.java:72)
        at com.tonbeller.tbutils.res.CompositeResourceProvider.close(CompositeResourceProvider.java:56)
        at com.tonbeller.tbutils.res.ResourcesFactory.initialize(ResourcesFactory.java:163)
        at com.tonbeller.tbutils.res.ResourcesFactory.<init>(ResourcesFactory.java:92)
        at com.tonbeller.tbutils.res.ResourcesFactory.<clinit>(ResourcesFactory.java:89)
        at com.tonbeller.tbutils.res.ResourcesFactoryContextListener.contextInitialized(ResourcesFactoryContextListener.java:23)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4939)
        at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5434)
        at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
 
 
Any ideas to a solution?
whiteboy_atl's picture
Joined: Dec 10 2013 - 10:35am
Last seen: 6 years 1 month ago

8 Answers:

13

Try adding a file named resfactory.properties under WEB-INF/classes containing the following line:

tbeller.usejndi=false

Also log a bug for this using the trackers, the file should be already there in the war but it's missing for some reason.

Regards,

Lucian

lucianc's picture
7269
Joined: Jul 17 2006 - 1:10am
Last seen: 2 weeks 1 day ago
3

Is it resolved in new versions as i still don't see the file in newer version 6.0.1

gupta_nikhil_badal's picture
Joined: Nov 3 2015 - 4:35am
Last seen: 2 years 5 months ago
0

It also can be, that you have a second applicationContext.xml file named like "applicationContexWhateverYouWant.xml" (I had it as a backup). I got this error as Spring was looking for "applicationContext*.xml".

If you want to have a backup call it applicationContext.xml.bkp or something like that, but after the file extension ".xml".

gawd's picture
2
Joined: Jul 12 2018 - 1:53am
Last seen: 1 year 10 months ago
2

This Problem still exists in newer versions :D 

SETTURGOPI's picture
Joined: Jul 12 2018 - 2:44am
Last seen: 2 months 3 weeks ago
1

I just installed version 7.2.0 of jasper server community, and the issue is still reproductible.

khaldi.yass's picture
Joined: May 27 2019 - 11:51am
Last seen: 1 year 1 day ago
1

+1 Jasper Server 7.2.0 has this issue.

moody.youssef's picture
Joined: Aug 4 2014 - 8:03am
Last seen: 3 weeks 3 days ago
1

I am having this same issue and its 2019 and this was posted 2013. wild. I have the exact same error, and adding the resfactory.properties file did not fix the error for me. Has anyone been able to get this sorted out? @moody.youseef @khaldi.yass @setturgopi @gawd @lucianc

mrobinson_3's picture
Joined: Sep 13 2019 - 10:02am
Last seen: 7 months 2 weeks ago
1

The support for Jasper Server is horrendous. About 5% of all reports we run fail with the above "error closing context' message, and after ***SEVEN (7) YEARS*** this issue is still present. I've tried about a dozen fixes I've found from all over the web, and nothing fixes the problem.

michael_56's picture
Joined: Jan 5 2016 - 2:06pm
Last seen: 2 months 2 weeks ago
Feedback
randomness