Group property "keep together" doesn't work with multiple headers

2

Hi,

I have a group with 5 headerbands.

Group properties that are true:

-Reprint header

-Keep together

Problem is that the first group header starts on the previous page if there's space. But the group would perfectly fit on the next page without breaks.

What could be wrong?

Using version 4.0.1

 

 

Attachments: 
roarf's picture
63
Joined: Mar 11 2010 - 2:51am
Last seen: 8 months 2 weeks ago
No one knows? Any help would be appriciated, have an upcoming release:)
roarf - 6 years 4 months ago
Or is it so that the group headers aren't supposed to be kept together with group?
roarf - 6 years 4 months ago

8 Answers:

0

Doesn't anyone know this? Seems like a bug..

roarf's picture
63
Joined: Mar 11 2010 - 2:51am
Last seen: 8 months 2 weeks ago
0

Can anyone help? It's critical, and there is no workaround

roarf's picture
63
Joined: Mar 11 2010 - 2:51am
Last seen: 8 months 2 weeks ago
0

hi  ,

Could you please put up a screen shot that would be more clear , what is the issue you are facing

 

Regards,

Ankur

Ankur Gupta's picture
Joined: Jan 21 2013 - 10:36pm
Last seen: 1 year 1 month ago

Done:)

roarf - 6 years 2 months ago
0

Hi ,

See the Keep Together function keeps the Header and Footer of a particular group together, and as you are pointing out that there are nested groups , try that the innermost group keeps together ,that might solve the problem .

Reprint header just does the job of placing headers on the every new page, but this also might have gone wrong due to the nested grouping. 

I would advice you to use a subreport , that would turn more handy, but this is just a suggestion , might or might not work in your case.

Hope that this helps.

 

Regards,

Ankur

Ankur Gupta's picture
Joined: Jan 21 2013 - 10:36pm
Last seen: 1 year 1 month ago

The 5 header bands are not nested but belong to the same group.. Use of subreport might be a workaround that would do the trick, but then I have to rewrite stuff, but thanks for the tip, it might be what I do if I can't get "keep togheter" to work properly

roarf - 6 years 2 months ago
0

you have to setting prevent first group header , and create header from other band

 

Regards, muzy

muzymuhammad's picture
Joined: Aug 30 2012 - 6:40pm
Last seen: 3 years 11 months ago
0

to muzy. What do you mean by "you have to setting prevent first group header , and create header from other band"

otiliai's picture
12
Joined: Apr 13 2009 - 12:23pm
Last seen: 2 years 4 months ago
0

Did you ever find a solution to your issue? I have a similar issue where I am rendering multiple images. The first image displays fine with the header on top, then the second header is at the bottom of the first page and image on the second page. I would like the second header and the respective image to show on the second page. I do have "Start a new Page" set for the group header as well as Keep together. I only have group header, no group footer is needed for my report. There is only one group in sub dataset source for my table.

singhpj's picture
Joined: Jun 13 2012 - 5:43pm
Last seen: 8 months 2 weeks ago
0

In this case you should use the Split Type band properties. If you set the split type to prevent, it will not allow data to be split

 

check this link http://community.jaspersoft.com/wiki/set-detail-band-property-split-type...

 

lwilli07's picture
Joined: Jun 6 2017 - 1:29pm
Last seen: 2 years 1 month ago
Feedback
randomness