Running iReport on OS/X with Oracle JDK7

With the oracle JDK installed it appears that iReport is not functioning correctly due to some class or AWT changes.  The Quit iReport menu item doesn't work at all, and there's no Preferences option on the application menu. Preferences don't appear to show up anywhere else on menus that I can find either. To quit the application, I have to use Force Quit.  My install is required to use Java7 due to the integration of some third party Java custom data sources, so using the stock Java 6 that comes with OS/X doesn't help at all. Right now, to do any configuration, I have to hand-edit the file. I've tried several tips, such as manually setting a few command line parameters to try to get it to understand that this is a normal JDK version, not the Apple platform version, but none seem to help.

Any suggestions on how to get this thing functioning like it should? Attached is a screen grab of the app menu showing the missing bits.

wethippie's picture
Joined: Sep 3 2012 - 4:46am
Last seen: 10 years 7 months ago

2 Answers:

I don't know which version of iReport you are using but this will works with all the 4.x and 5.x versions. I had iReport installed on my Mac before the Java7 update so I did not see any issues. What you can do is tell iReport to use the 1.6 or 1.5 JDK or JRE

If you go to your application folder Applications/iReportPro-5.0.0/. Right click on Jaspersoft iReport Designer and select "Show package Contents".

Once there navgate to /Contents/Resources/ireportpro/etc/ and open ireportpro.conf in your favorite text editor. And edit the default JDK/JRW location to point to the Previous JDK/JRE version. Sample below:


# ${HOME} will be replaced by user home directory according to platform
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/5.0.0"
# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="-J-Xms24m -J-Xmx512m -J-Dorg.netbeans.ProxyClassLoader.level=1000 -J-XX:MaxPermSize=256m"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea
# default location of JDK/JRE, can be overridden by using --jdkhome switch
# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)
marianol's picture
Joined: Sep 13 2011 - 8:04am
Last seen: 4 years 12 months ago

Thanks. I know it works with previous versions of java, but as I stated in my original post, I'm required to use Java 7 due to external dependencies.

FWIW, the same problem has existed from iReport from 4.5 through to the current 5.0.1.

wethippie - 10 years 7 months ago

Have you tried using Jaspersoft Studio Instead? the new version 2 is pretty solid and will do all iReport does plus some extra features.

Just out of curiosity, since you are using iReport as a stand alone, what dependencies you have on Java 7? scriptlets?

marianol - 10 years 7 months ago

I saw that it got released a few days ago. Shied away from 1.x because it was horribly unstable, particularly for use with business users. I'm going to give it a go and see if the stability is better. Will report back in a few days.

The dependencies are on a collection of custom query executors and data sources. Thankfully no query designers or stuff at the desktop tool level that would need to be ported.

wethippie - 10 years 7 months ago

iReport Designer 5.5.0 com jdk 7

No Mac OS X Maverick, altere o arquivo ireport.conf no diretorio /Applications/Jaspersoft iReport

Altere a linha  #jdkhome="/path/to/jdk"

para  jdkhome="/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home"


adriano70's picture
Joined: Sep 15 2010 - 4:55am
Last seen: 9 years 8 months ago