when running scriptlet on jasperserver get "Unsupported major.minor version 51.0" error

0

Hello,

 

I am attempting to add a scriptlet to my jaspersoft report, and as of right now using a test one to see if I can get it working, and I'm getting the following error:

"java.lang.UnsupportedClassVersionError: com/sadakar/jasper/Test4 : Unsupported major.minor version 51.0"

The Jasperserver is at version 3.5.1 and I am unable to chnage any configurations on the server side.

Is this an issue regarding the java code or does the jasperserver not support it?

 

Thanks for any help.

chrisj.msac's picture
Joined: Mar 1 2018 - 4:13pm
Last seen: 1 year 4 months ago

2 Answers:

1

Jasperserver 3.5.1 is too old. Try versioning it up to at least 6.2.x

hozawa's picture
45019
Joined: Apr 24 2010 - 4:31pm
Last seen: 1 month 1 week ago
0

@hozwa

So any Jasperserver under 6.2.x is too old?

Thank you for your response.

chrisj.msac's picture
Joined: Mar 1 2018 - 4:13pm
Last seen: 1 year 4 months ago
Feedback
randomness